profiles/f/p/s/legacy/profile.bashrc: disable utimensat syscall
authorBenda Xu <heroxbd@gentoo.org>
Mon, 5 Jun 2017 06:22:28 +0000 (15:22 +0900)
committerBenda Xu <heroxbd@gentoo.org>
Mon, 5 Jun 2017 06:23:51 +0000 (15:23 +0900)
  cmake based build system does not provide an interface to override
  compile checks, therefore this hack.

profiles/features/prefix/standalone/legacy/profile.bashrc [new file with mode: 0644]

diff --git a/profiles/features/prefix/standalone/legacy/profile.bashrc b/profiles/features/prefix/standalone/legacy/profile.bashrc
new file mode 100644 (file)
index 0000000..e537cc0
--- /dev/null
@@ -0,0 +1,6 @@
+# tricks to circumvent false positive checks of old kernel
+
+if [[ ${CATEGORY}/${PN} == dev-util/cmake && ${EBUILD_PHASE} == configure ]]; then
+    einfo "Removing utimensat outputs..."
+    sed -i '/UTIMENSAT=/d' ${S}/Source/kwsys/CMakeLists.txt
+fi