nose_warnings_filters: add python3_8
authorAndrey Grozin <grozin@gentoo.org>
Sun, 1 Mar 2020 04:42:11 +0000 (11:42 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sun, 1 Mar 2020 04:42:11 +0000 (11:42 +0700)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild [new file with mode: 0644]

diff --git a/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild b/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild
new file mode 100644 (file)
index 0000000..b550c93
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module to inject warning filters during nosetest"
+HOMEPAGE="https://github.com/Carreau/nose_warnings_filters"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( ${RDEPEND} )"
+
+python_test() {
+       # nose_warnings_filters doesn't have a proper
+       # testing suite, hence we run the only testing
+       # script available
+       distutils_install_for_testing
+       cd "${TEST_DIR}"/lib || die
+       "${EPYTHON}" "${S}"/${PN}/testing/test_config.py || die "Failed running test script"
+}