dev-python/doublex: 1.9.2 + EAPI 7 + py37
authorSebastian Pipping <sping@gentoo.org>
Sat, 29 Feb 2020 21:32:53 +0000 (22:32 +0100)
committerSebastian Pipping <sping@gentoo.org>
Sat, 29 Feb 2020 21:38:50 +0000 (22:38 +0100)
Bug: https://bugs.gentoo.org/711092
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.84, Repoman-2.3.20

dev-python/doublex/Manifest
dev-python/doublex/doublex-1.9.2.ebuild [new file with mode: 0644]

index b75a1fe16d91c2031ef9ca5ae01466c48a8b6896..61bc4b3c91570296d0abf5c12fb72f81269cac0c 100644 (file)
@@ -1 +1,2 @@
 DIST doublex-1.8.1.tar.gz 69685 BLAKE2B 38f80ac0cf68dc2401eaa8051542c91d382e9ba22ed229b3c12a192f0b180b33a5660e54f647b2273401500a3292619d918dde9b0f685807217bca40e1aafbfc SHA512 30d2b572862370da8402cc2cfa5481d3278f0fefd2d5b2f5be126a793c8e165df0e2ae6089ba321e71d994f14024b882933c1523f7a0b9e341bf75644b49e073
+DIST doublex-1.9.2.tar.gz 80246 BLAKE2B 7fc1c4e6d117bee13e7125b634293aa7c9d1016c9cd5201f047143bcb1fae1e9607bf0a030cbaa2d6eb930474babe29aaf244433aba57ae4325a3a43af2fdf56 SHA512 0278f756930b0d5c3da676e3908ccc17b919c14f740aace3002f5117fa341ac52fe16fdaa2c3b36029757dd1dc2f36d8d35cdc8664fcfdbcafd4809d2fc969b0
diff --git a/dev-python/doublex/doublex-1.9.2.ebuild b/dev-python/doublex/doublex-1.9.2.ebuild
new file mode 100644 (file)
index 0000000..6c9f288
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# tests are failing with Python 3.8
+# https://bitbucket.org/DavidVilla/python-doublex/issues/5/support-for-python-36-36-38-tests-failing
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python test doubles"
+HOMEPAGE="https://bitbucket.org/DavidVilla/python-doublex"
+SRC_URI="https://bitbucket.org/DavidVilla/python-${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-python/pyhamcrest[${PYTHON_USEDEP}]"
+DEPEND="
+       ${CDEPEND}
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND="${CDEPEND}"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+       use doc && emake -C docs
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+
+       distutils-r1_python_install_all
+
+       rm "${ED}"/usr/README.rst || die "Couldn't remove spurious README.rst"
+}