app-editors/wily: EAPI=7
authorJeroen Roovers <jer@gentoo.org>
Mon, 14 Jan 2019 00:04:20 +0000 (01:04 +0100)
committerJeroen Roovers <jer@gentoo.org>
Mon, 14 Jan 2019 00:04:53 +0000 (01:04 +0100)
Package-Manager: Portage-2.3.55, Repoman-2.3.12
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
app-editors/wily/wily-1.0-r2.ebuild [new file with mode: 0644]

diff --git a/app-editors/wily/wily-1.0-r2.ebuild b/app-editors/wily/wily-1.0-r2.ebuild
new file mode 100644 (file)
index 0000000..0266f79
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib toolchain-funcs
+
+MY_P="${P/1.0/9libs}"
+
+DESCRIPTION="An emulation of ACME, Plan9's hybrid window system, shell and editor"
+HOMEPAGE="https://www.netlib.org/research/9libs/"
+SRC_URI="${HOMEPAGE}${MY_P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="
+       dev-libs/9libs[X]
+"
+RDEPEND="
+       ${DEPEND}
+"
+DOCS=(
+       README
+)
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+       tc-export CC
+
+       mhw_cv_mod_9libs_lib_path=/usr/$(get_libdir) \
+       mhw_cv_mod_9libs_inc_path=/usr/include/9libs \
+       econf
+}
+
+src_install() {
+       default
+
+       insinto /usr/share/${PN}
+       doins "${S}"/misc/*
+}