games-board/four-in-a-row: bump to 3.32.0
authorMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 16:44:21 +0000 (19:44 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 16:44:21 +0000 (19:44 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
games-board/four-in-a-row/Manifest
games-board/four-in-a-row/four-in-a-row-3.32.0.ebuild [new file with mode: 0644]

index 409c449d3a24cbdd85d99abde0a5e0755a5c4819..ae133a0ea7a538b7003223bdbb63f50f4bdbef9f 100644 (file)
@@ -1 +1,2 @@
 DIST four-in-a-row-3.28.0.tar.xz 740784 BLAKE2B f5d2af3514e7629026da5f1aedf22945eddb44b6917922d175f4e5aa160ea7266e0ab101866c1d5220d0e835e60544e4ec8fc6016d908e580a7b1057fc8db7f0 SHA512 a13d6db2c32cc19e8504c1e8baa7b0e28f59e3fc604940d51742d3fd2b266ac90a92e638df2449bcca5e828923c7ee9ff1424a095a98fd5e1d76426a444d7ede
+DIST four-in-a-row-3.32.0.tar.xz 507596 BLAKE2B 8253c1f44d7c3e27d2e3fe64984aff5485569496d85a77a48b2fd67fee065377f4667b92524481838787c0b7f27e16250b0aa1bc53ff470624f9da92187b7e44 SHA512 f74dcb072c4da03b8cfc274d92a0eda8ca1fbea4b216b4add793155ae63bd8cc1c784ea2b553a198616dbc2254bb1d5567ddc1608f027eaf6e0a594741a2ab96
diff --git a/games-board/four-in-a-row/four-in-a-row-3.32.0.ebuild b/games-board/four-in-a-row/four-in-a-row-3.32.0.ebuild
new file mode 100644 (file)
index 0000000..51c29bd
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Make lines of the same color to win"
+HOMEPAGE="https://wiki.gnome.org/Apps/Four-in-a-row"
+
+# Code and most themes are GPL-3+, CC-BY-SA-3.0 is user help license in v3.32.0
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=dev-libs/glib-2.40.0:2
+       >=x11-libs/gtk+-3.13.2:3
+       >=gnome-base/librsvg-2.32.0
+       >=media-libs/libcanberra-0.26[gtk3]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       $(vala_depend)
+       dev-libs/appstream-glib
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       xdg_src_prepare
+       vala_src_prepare
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}