dev-util/clion: version bump to 2020.1
authorChristian Strahl <c.a.strahl@gmail.com>
Tue, 14 Apr 2020 21:00:59 +0000 (23:00 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 16 Apr 2020 08:09:50 +0000 (11:09 +0300)
Package-Manager: Portage-2.3.89-r1, Repoman-2.3.20
Signed-off-by: Christian Strahl <c.a.strahl@gmail.com>
Closes: https://bugs.gentoo.org/717458
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-util/clion/Manifest
dev-util/clion/clion-2020.1.ebuild [new file with mode: 0644]

index 05b8bc0da2089fb2569bf661d5a525651fc9f1bc..a518304da61cfcb80c515ef35d3dd63193535493 100644 (file)
@@ -1 +1,2 @@
 DIST clion-2019.3.5.tar.gz 509223445 BLAKE2B 94429d0f1d32185ca8d172cdfe7583e6042a5c24b10387ef265ddafbb19e3dc379589a3992b306dfc225449b8a781be996c0d4d4308252c60dc74fa20ffebab7 SHA512 9522209ecef2b025e818ac488c7c842c7170629a8fb38e6efa578cdd6973004da5ee423ea5913e6a61595fea653facaf741f513e2b47701e78749f8188c45583
+DIST clion-2020.1.tar.gz 510270266 BLAKE2B 4231737d972a8cde9a84db9c9c3a6478a7bba1eb3df11066b2808a016bfda47b4a4d22cee465d628ab03e4656acc087bcd31733112fa5a79807de6ddee5475bb SHA512 eb0d04646df482c7b42bdbc1df6cfbe46ddae6c98f73b1a9d5ad2560efb25a088be2a95eebd1e21981490b79600705c36f723310b7dedc89531296268acd24f6
diff --git a/dev-util/clion/clion-2020.1.ebuild b/dev-util/clion/clion-2020.1.ebuild
new file mode 100644 (file)
index 0000000..d50ca20
--- /dev/null
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils
+
+DESCRIPTION="A complete toolset for C and C++ development"
+HOMEPAGE="https://www.jetbrains.com/clion"
+SRC_URI="https://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( IDEA IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )
+       Apache-1.1 Apache-2.0 BSD BSD-2 CC0-1.0 CDDL-1.1 CPL-0.5 CPL-1.0
+       EPL-1.0 EPL-2.0 GPL-2 GPL-2-with-classpath-exception GPL-3 ISC JDOM
+       LGPL-2.1+ LGPL-3 MIT MPL-1.0 MPL-1.1 OFL public-domain PSF-2 UoI-NCSA ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist mirror splitdebug"
+IUSE="custom-jdk"
+
+# RDEPENDS may cause false positives in repoman.
+# clion requires cmake and gdb at runtime to build and debug C/C++ projects
+RDEPEND="
+       dev-libs/libdbusmenu
+       dev-util/cmake
+       sys-devel/gdb
+       !custom-jdk? ( virtual/jdk )"
+
+QA_PREBUILT="opt/${P}/*"
+
+src_prepare() {
+       default
+
+       local remove_me=(
+               bin/gdb/linux
+               bin/lldb/linux
+               bin/cmake
+               license/CMake*
+               lib/pty4j-native/linux/ppc64le
+       )
+
+       use amd64 || remove_me+=( bin/fsnotifier64 lib/pty4j-native/linux/x86_64)
+       use x86 || remove_me+=( bin/fsnotifier lib/pty4j-native/linux/x86)
+
+       use custom-jdk || remove_me+=( jbr )
+
+       rm -rv "${remove_me[@]}" || die
+}
+
+src_install() {
+       local dir="/opt/${P}"
+
+       insinto "${dir}"
+       doins -r *
+       fperms 755 "${dir}"/bin/{clion.sh,clang/linux/clang{d,-tidy}}
+
+       if use amd64; then
+               fperms 755 "${dir}"/bin/fsnotifier64
+       fi
+       if use arm; then
+               fperms 755 "${dir}"/bin/fsnotifier-arm
+       fi
+       if use x86; then
+               fperms 755 "${dir}"/bin/fsnotifier
+       fi
+
+       if use custom-jdk; then
+               if [[ -d jbr ]]; then
+               fperms 755 "${dir}"/jbr/bin/{jaotc,java,javac,jdb,jjs,jrunscript,keytool,pack200,rmid,rmiregistry,serialver,unpack200}
+               fi
+       fi
+
+       make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
+       newicon "bin/${PN}.svg" "${PN}.svg"
+       make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
+
+       # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+       dodir /usr/lib/sysctl.d/
+       echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
+}