app-misc/spacenavd: Support GCC 10
authorSebastian Pipping <sping@gentoo.org>
Sat, 1 Feb 2020 19:51:56 +0000 (20:51 +0100)
committerSebastian Pipping <sping@gentoo.org>
Sat, 1 Feb 2020 19:53:07 +0000 (20:53 +0100)
Bug: https://bugs.gentoo.org/706966
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.84, Repoman-2.3.20

app-misc/spacenavd/spacenavd-0.6.ebuild

index 86b0c8ae31567beec99ff32a5a442c5e9ec0de0b..bbf5b9cf9e04004fa897a7a37d2508034a8c70d1 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
 
-inherit linux-info systemd toolchain-funcs udev
+inherit epatch linux-info systemd toolchain-funcs udev
 
 MY_PN='spacenav'
 DESCRIPTION="The spacenavd daemon provides free alternative to the 3dxserv daemon"
@@ -23,6 +23,11 @@ pkg_setup() {
        check_extra_config
 }
 
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-0.7-gcc10.patch
+       default
+}
+
 src_configure() {
        econf \
                --disable-debug \