net-libs/zeromq: bump to v4.3.1
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 14 Jan 2019 02:19:03 +0000 (03:19 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 14 Jan 2019 02:19:15 +0000 (03:19 +0100)
Bug: https://bugs.gentoo.org/675376
Package-Manager: Portage-2.3.55, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
net-libs/zeromq/Manifest
net-libs/zeromq/zeromq-4.3.1.ebuild [new file with mode: 0644]

index 0a27ae6101fec4f0b82a1044d47b734753b7ea13..611ca7c0ce5d740111ad43b2c4ee2fcb9a4ee716 100644 (file)
@@ -9,3 +9,4 @@ DIST zeromq-4.2.2.tar.gz 1236437 BLAKE2B 7104f8ad28cc00f1ba6d6cb5dbb9aa466971c73
 DIST zeromq-4.2.3.tar.gz 1326780 BLAKE2B f76ff6461e5a180221b1fff471e795a457fe4f26ec1ca725438aff4e240be7da80e42b2aea49845b5712e1d63590f64bc681f9a793bcf4d32fe0ee08bcab482c SHA512 8ac588a7a4db9d65586dd7b501999edac151e1d03056c1014d7ded6cd4bcf5bb4f81252b47d89d60c3ad7d527685218992bf5853b4656c0702e0f64c2d77712b
 DIST zeromq-4.2.5.tar.gz 1409447 BLAKE2B 9309cff20192c4e0d9e34992cc3168c219ae63e8258362483d15f3315436324454603739393d2fa2628fb4cf7a94954c1643de07c3a28e86933fcd53aa2e0fac SHA512 4556cb50d05a6d133015a0ba804d6d951a47479a33fa29561eaeecb93d48b7bb6477365d0986c38b779f500cadaf08522c4a7aa13f5510303bd923f794d37036
 DIST zeromq-4.3.0.tar.gz 1487771 BLAKE2B 3783eb2505c2e42fc2c03cd9a280b0e2a70758d4046bd0c5b0f43a5a0630655ff06665c30fdfe222fb077ff966a9d5e0c762f65370804dee2eb25fa8215d5e2b SHA512 593239f66c4157e596874832378c9405d79c915a5895503bdbc87304df0ab49311b96f92ba6492396b4bf25d2007689099730995f7c335a51fbf42a9aafb02e4
+DIST zeromq-4.3.1.tar.gz 1490122 BLAKE2B 95d0a1359e85a3868ae0b1cd4f711d9715ddc07d21fbb7799c6beaa269aa77fb68e087898033f8a515be974a799c1ee2f2afba1f50b1bc806255750b95990367 SHA512 b80388a3703993425cdd73054139a8e2895aedb9992ea68d6eadb4ea39b9af576ea14f306dfb432e4c24535feb6b293f82fac5679b655d258f0f921f2b71e772
diff --git a/net-libs/zeromq/zeromq-4.3.1.ebuild b/net-libs/zeromq/zeromq-4.3.1.ebuild
new file mode 100644 (file)
index 0000000..ab8a55e
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="A brokerless kernel"
+HOMEPAGE="http://www.zeromq.org/"
+SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc drafts pgm +sodium static-libs test unwind elibc_Darwin"
+
+RDEPEND="
+       !elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
+       sodium? ( dev-libs/libsodium:= )
+       pgm? ( =net-libs/openpgm-5.2.122 )"
+DEPEND="${RDEPEND}
+       !elibc_Darwin? ( sys-apps/util-linux )
+       doc? (
+               app-text/asciidoc
+               app-text/xmlto
+       )
+       pgm? ( virtual/pkgconfig )"
+
+PATCHES=()
+
+src_prepare() {
+       sed \
+               -e '/libzmq_werror=/s:yes:no:g' \
+               -i configure.ac || die
+       default
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               --enable-shared
+               $(use_enable drafts)
+               $(use_enable static-libs static)
+               $(use_enable unwind libunwind)
+               $(use_with sodium libsodium)
+               $(use_with pgm)
+               $(use_with doc docs)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_test() {
+       # Restricting to one job because multiple tests are using the same port.
+       # Upstream knows the problem and says it doesn't support parallel test
+       # execution, see ${S}/INSTALL.
+       emake -j1 check
+}
+
+src_install() {
+       default
+       find "${ED%/}"/usr/lib* -name '*.la' -delete || die
+}