dev-python/dockerpty: EAPI 7 + py37
authorSebastian Pipping <sping@gentoo.org>
Sat, 29 Feb 2020 22:32:27 +0000 (23:32 +0100)
committerSebastian Pipping <sping@gentoo.org>
Sat, 29 Feb 2020 22:32:27 +0000 (23:32 +0100)
Bug: https://bugs.gentoo.org/711092
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.84, Repoman-2.3.20

dev-python/dockerpty/dockerpty-0.4.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/dockerpty/dockerpty-0.4.1-r1.ebuild b/dev-python/dockerpty/dockerpty-0.4.1-r1.ebuild
new file mode 100644 (file)
index 0000000..ce54aae
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to use the pseudo-tty of a docker container"
+HOMEPAGE="https://github.com/d11wtq/dockerpty"
+SRC_URI="https://github.com/d11wtq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+       test? (
+               >=dev-python/docker-py-0.7.0_rc2[${PYTHON_USEDEP}]
+               >=dev-python/expects-0.4[${PYTHON_USEDEP}]
+               >=dev-python/pytest-2.5.2[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND=">=dev-python/six-1.3.0[${PYTHON_USEDEP}]"
+
+python_test() {
+       py.test tests || die "Tests failed under ${EPYTHON}"
+}