sys-libs/ldb: Bump to versions 2.0.10 and 2.1.2
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 29 Apr 2020 08:51:48 +0000 (10:51 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 29 Apr 2020 09:38:36 +0000 (11:38 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-libs/ldb/Manifest
sys-libs/ldb/ldb-2.0.10.ebuild [new file with mode: 0644]
sys-libs/ldb/ldb-2.1.2.ebuild [new file with mode: 0644]

index 7b5c810d5cd7039f430b29f88f526739929279dd..500c5daa7ed70198f21b917b5b18a9e0dd86f410 100644 (file)
@@ -1,3 +1,5 @@
+DIST ldb-2.0.10.tar.gz 1676630 BLAKE2B 9ae9e6579fd7b15b91a4c0f52ad5ea3a9ba3135efe408b76db53db211a48d3952a790f2f856e5f9573174b2203840b7d6a6ad10976a4b6bf3e0d294731b89b31 SHA512 51954969e3121295ea99856c254f455cb746102e9d7895fbd7c66997f33763ae4522ed456e4bae7921b2edd73575a0a10738d21a90a067a57ff770cf0fe35aef
 DIST ldb-2.0.8.tar.gz 1676902 BLAKE2B b86b24a597bd81ae11382311f3b60aeb8aca78ddbe63413b9a8cdbbfa4f52b05a0d2e325d483e260b15aa396c2ad9f2828ac4b6214af86d891281d05b24125b5 SHA512 23a44968c9b4b57deb3f7b7b2466f140b4d8534a07a5e866545dd108c3d305ee4b0ea9bceec3177fcd09a4efcb4876a8283ca58b5c496fcf323b810666e1e79a
 DIST ldb-2.0.9.tar.gz 1676176 BLAKE2B 0d18a570ca61fcdf159b6398ecef74bc983c24ffd4d8f85bc9cfcbb182f787d0deb50c5f446684b851993146e03bdaf10d80c083a9534446b829714fff025b8f SHA512 f4d2480491f16aac7837fa2ff071e81e429bd9b3a365264723245791aad1831a236ffeff0f01f85becb998b224c321b166f3edd3f9a828714b7c3b24aed11a5e
 DIST ldb-2.1.1.tar.gz 1671390 BLAKE2B a715cb17a2d113560d37e3e5d29adfe7db43f89388bb5a474388e3f7a6ae277ddb0ee4d09d45eed18a87085c70d98308d195b3867cc57259767cb61a50c8cc6e SHA512 dd87da0746790895c617108c64b718ab6e6e630f1e3269154b40fc0e5623199a4b132d41623ae00d5c263ce79c4d6da34f072a140bee91a59dd6934969315fc8
+DIST ldb-2.1.2.tar.gz 1670997 BLAKE2B 0622d39029819b89119bce6a570c56b247871a92685d4ca33153a141d4cbbcb52a041a33c6ddbf6b01d5195feeb49fcf24f15a571cad99d031f347374860b3fe SHA512 6b9a7e6e3f6532ccedb087394b1d2d28f53a034353288bac1ea8d9ca65da5981191e31de6493445daa87684e08cc587886dd7fce19391bd20f1c7d440dbf3fbf
diff --git a/sys-libs/ldb/ldb-2.0.10.ebuild b/sys-libs/ldb/ldb-2.0.10.ebuild
new file mode 100644 (file)
index 0000000..484c8a1
--- /dev/null
@@ -0,0 +1,108 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-single-r1 waf-utils multilib-minimal eutils
+
+DESCRIPTION="An LDAP-like embedded database"
+HOMEPAGE="https://ldb.samba.org"
+SRC_URI="https://www.samba.org/ftp/pub/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc +ldap +lmdb python test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+       dev-libs/popt[${MULTILIB_USEDEP}]
+       >=dev-util/cmocka-1.1.3[${MULTILIB_USEDEP}]
+       >=sys-libs/talloc-2.2.0[python?,${MULTILIB_USEDEP}]
+       >=sys-libs/tdb-1.4.2[python?,${MULTILIB_USEDEP}]
+       >=sys-libs/tevent-0.10.0[python(+)?,${MULTILIB_USEDEP}]
+       ldap? ( net-nds/openldap )
+       lmdb? ( >=dev-db/lmdb-0.9.16[${MULTILIB_USEDEP}] )
+       python? ( ${PYTHON_DEPS} )
+"
+
+DEPEND="dev-libs/libxslt
+       doc? ( app-doc/doxygen )
+       virtual/pkgconfig
+       ${PYTHON_DEPS}
+       ${RDEPEND}
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+       test? ( python )"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+MULTILIB_WRAPPED_HEADERS=( /usr/include/pyldb.h )
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.5.2-optional_packages.patch
+       "${FILESDIR}"/${PN}-1.1.31-fix_PKGCONFIGDIR-when-python-disabled.patch
+)
+
+pkg_setup() {
+       python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       local myconf=(
+               $(usex ldap '' --disable-ldap)
+               $(usex lmdb '' --without-ldb-lmdb)
+               --disable-rpath
+               --disable-rpath-install --bundled-libraries=NONE
+               --with-modulesdir="${EPREFIX}"/usr/$(get_libdir)/samba
+               --builtin-libraries=NONE
+       )
+       if ! multilib_is_native_abi; then
+               myconf+=( --disable-python )
+       else
+               use python || myconf+=( --disable-python )
+       fi
+       waf-utils_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+       waf-utils_src_compile
+       multilib_is_native_abi && use doc && doxygen Doxyfile
+}
+
+multilib_src_test() {
+       if multilib_is_native_abi; then
+               WAF_MAKE=1 \
+               PATH=buildtools/bin:../../../buildtools/bin:$PATH:"${BUILD_DIR}"/bin/shared/private/ \
+               LD_LIBRARY_PATH=$LD_LIBRARY_PATH:"${BUILD_DIR}"/bin/shared/private/:"${BUILD_DIR}"/bin/shared \
+               waf test || die
+       fi
+}
+
+multilib_src_install() {
+       waf-utils_src_install
+
+       if multilib_is_native_abi && use doc; then
+               doman  apidocs/man/man3/*.3
+               docinto html
+               dodoc -r apidocs/html/*
+       fi
+}
+
+pkg_postinst() {
+       if has_version sys-auth/sssd; then
+               ewarn "You have sssd installed. It is known to break after ldb upgrades,"
+               ewarn "so please try to rebuild it before reporting bugs."
+               ewarn "See https://bugs.gentoo.org/404281"
+       fi
+}
diff --git a/sys-libs/ldb/ldb-2.1.2.ebuild b/sys-libs/ldb/ldb-2.1.2.ebuild
new file mode 100644 (file)
index 0000000..e1deb52
--- /dev/null
@@ -0,0 +1,108 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-single-r1 waf-utils multilib-minimal eutils
+
+DESCRIPTION="An LDAP-like embedded database"
+HOMEPAGE="https://ldb.samba.org"
+SRC_URI="https://www.samba.org/ftp/pub/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc +ldap +lmdb python test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+       dev-libs/popt[${MULTILIB_USEDEP}]
+       >=dev-util/cmocka-1.1.3[${MULTILIB_USEDEP}]
+       >=sys-libs/talloc-2.3.1[python?,${MULTILIB_USEDEP}]
+       >=sys-libs/tdb-1.4.3[python?,${MULTILIB_USEDEP}]
+       >=sys-libs/tevent-0.10.2[python(+)?,${MULTILIB_USEDEP}]
+       ldap? ( net-nds/openldap )
+       lmdb? ( >=dev-db/lmdb-0.9.16[${MULTILIB_USEDEP}] )
+       python? ( ${PYTHON_DEPS} )
+"
+
+DEPEND="dev-libs/libxslt
+       doc? ( app-doc/doxygen )
+       virtual/pkgconfig
+       ${PYTHON_DEPS}
+       ${RDEPEND}
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+       test? ( python )"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+MULTILIB_WRAPPED_HEADERS=( /usr/include/pyldb.h )
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.5.2-optional_packages.patch
+       "${FILESDIR}"/${PN}-1.1.31-fix_PKGCONFIGDIR-when-python-disabled.patch
+)
+
+pkg_setup() {
+       python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       local myconf=(
+               $(usex ldap '' --disable-ldap)
+               $(usex lmdb '' --without-ldb-lmdb)
+               --disable-rpath
+               --disable-rpath-install --bundled-libraries=NONE
+               --with-modulesdir="${EPREFIX}"/usr/$(get_libdir)/samba
+               --builtin-libraries=NONE
+       )
+       if ! multilib_is_native_abi; then
+               myconf+=( --disable-python )
+       else
+               use python || myconf+=( --disable-python )
+       fi
+       waf-utils_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+       waf-utils_src_compile
+       multilib_is_native_abi && use doc && doxygen Doxyfile
+}
+
+multilib_src_test() {
+       if multilib_is_native_abi; then
+               WAF_MAKE=1 \
+               PATH=buildtools/bin:../../../buildtools/bin:$PATH:"${BUILD_DIR}"/bin/shared/private/ \
+               LD_LIBRARY_PATH=$LD_LIBRARY_PATH:"${BUILD_DIR}"/bin/shared/private/:"${BUILD_DIR}"/bin/shared \
+               waf test || die
+       fi
+}
+
+multilib_src_install() {
+       waf-utils_src_install
+
+       if multilib_is_native_abi && use doc; then
+               doman  apidocs/man/man3/*.3
+               docinto html
+               dodoc -r apidocs/html/*
+       fi
+}
+
+pkg_postinst() {
+       if has_version sys-auth/sssd; then
+               ewarn "You have sssd installed. It is known to break after ldb upgrades,"
+               ewarn "so please try to rebuild it before reporting bugs."
+               ewarn "See https://bugs.gentoo.org/404281"
+       fi
+}