games-board/cockatrice: version bump to 20160630.
authorGuillaume Seren <guillaumeseren@gmail.com>
Tue, 8 Nov 2016 17:31:49 +0000 (18:31 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Wed, 21 Dec 2016 10:46:07 +0000 (11:46 +0100)
"Archivist Madness"

Release notes: https://github.com/Cockatrice/Cockatrice/releases/tag/2016-06-30-Release

Closes: https://github.com/gentoo/gentoo/pull/2780

games-board/cockatrice/Manifest
games-board/cockatrice/cockatrice-20160630.ebuild [new file with mode: 0644]

index ca33575c7c1f52016176d224a6775b0e84fafe00..0ad7ff7cca90b7179dbd19f0aeb4e62621597f54 100644 (file)
@@ -1 +1,2 @@
 DIST cockatrice-20160506.tar.gz 6910937 SHA256 379835006f38b603af01cf46d508fd40e862b451045807b444042914e8736fee SHA512 5f90804270907b3a915e763e6a20c39432f76591a11df7198526fde5635314ffbb27026860053c302be1ef1dfce1efa445c5849c72d1220575314d6c3d67e94f WHIRLPOOL a13c531980da2cf172e933c5bcb179f8dc9368514fe7d2ec12a203f54c04aa5258218c6d2fc1bee30826598e1e8c057c437af6810709c26b0863cd2b665bc159
+DIST cockatrice-20160630.tar.gz 6928656 SHA256 18c7ec245be8600d4c4be5868b71238ec669a38a24053d84aed608dae888a6f5 SHA512 a208b0e754285f9dd9f1f0bd28dbb29d97edf2d40da02bbe4dd6d6f01cfdff6fdc978ceaaf3d251252a69318519283790fa7ed5c552b08142e849e0b7c18d4cd WHIRLPOOL c339974104dc697f27c92263460b9dcd892819c0f7797247d3479bfb54b998118c22e7441ce9877749f6ffc265d7d5a6b5b5aa62bea1b0108fa558e0cc237e4d
diff --git a/games-board/cockatrice/cockatrice-20160630.ebuild b/games-board/cockatrice/cockatrice-20160630.ebuild
new file mode 100644 (file)
index 0000000..17e5d87
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils eutils gnome2-utils
+
+DESCRIPTION="An open-source multiplatform software for playing card games over a network"
+HOMEPAGE="https://github.com/Cockatrice/Cockatrice"
+
+SRC_URI="https://github.com/Cockatrice/${PN}/archive/2016-06-30-Release.tar.gz -> ${P}.tar.gz"
+# As the default help/about display the sha1 we need it
+SHA1='277d7e2'
+S=${WORKDIR}/"Cockatrice-2016-06-30-Release"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated server"
+
+DEPEND="
+       dev-libs/libgcrypt:0
+       dev-libs/protobuf
+       dev-qt/linguist-tools:5
+       dev-qt/qtconcurrent:5
+       dev-qt/qtcore:5
+       dev-qt/qtprintsupport:5
+       !dedicated? (
+               dev-qt/qtgui:5
+               dev-qt/qtmultimedia:5
+               dev-qt/qtsvg:5
+       )"
+
+src_configure() {
+       local mycmakeargs=(
+               $(usex dedicated "-DWITHOUT_CLIENT=1 -DWITH_SERVER=1" "$(usex server "-DWITH_SERVER=1" "")")
+               -DICONDIR="/usr/share/icons"
+               -DDESKTOPDIR="/usr/share/applications"
+       )
+
+       # Add date in the help about, come from git originally
+       sed -i 's/^set(PROJECT_VERSION_FRIENDLY.*/set(PROJECT_VERSION_FRIENDLY \"'${SHA1}'\")/' cmake/getversion.cmake || die "Sed failed!"
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+}
+
+src_install() {
+       cmake-utils_src_install
+}
+
+pkg_preinst() {
+       use dedicated || gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       #FIXME:
+       elog "zonebg pictures are in ${GAMES_DATADIR}/${PN}/zonebg"
+       elog "sounds are in ${GAMES_DATADIR}/${PN}/sounds"
+       elog "you can use those directories in cockatrice settings"
+       use dedicated || gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       use dedicated || gnome2_icon_cache_update
+}