app-misc/asciinema: version bump 2.0.0
authorMichael Palimaka <kensington@gentoo.org>
Fri, 16 Feb 2018 11:13:18 +0000 (22:13 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Fri, 16 Feb 2018 11:13:27 +0000 (22:13 +1100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-misc/asciinema/Manifest
app-misc/asciinema/asciinema-2.0.0.ebuild [new file with mode: 0644]

index 80961aa68d2e9951ee687f9022717b6c3f686f15..ff153dda52a51d515075f117e47dbf3ca1c9bb8c 100644 (file)
@@ -1 +1,2 @@
 DIST asciinema-1.4.0.tar.gz 35264 BLAKE2B 7a6eb179206afdcbe8d1a68cc7bdd7246cbb8d5ace870da40db2a1159a71f7cb18133c0bf286f0b0c1a4d2b7779fec9d1af602ca8b14d2fce478b84fe0e8adf4 SHA512 23c67a462acdbbbed495e6cc3e0e22ed028effcc945af30b5925854e216c6f74bb1b416d9b0001726732ae8be510796e996bbca69b225c20422143e5ed1aca5c
+DIST asciinema-2.0.0.tar.gz 47724 BLAKE2B 28ee2f19bdd7ca27720713af86492d2ac2d3acd53cadfdc82c613e187bcdb4d349c0a7629b7c48630b80c2f62bd20db25ebea43471bd04f205c2afca15b8b9c3 SHA512 af11134af1e69eabbf5a177000026830d418ed5d91e381f27c0631692bbaae04afc3f1086ea2065c54f49f227f7e575938c69d6d3bc8b5f9f06eca3fe084598e
diff --git a/app-misc/asciinema/asciinema-2.0.0.ebuild b/app-misc/asciinema/asciinema-2.0.0.ebuild
new file mode 100644 (file)
index 0000000..802f14d
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="Command line recorder for asciinema.org service"
+HOMEPAGE="https://asciinema.org/ https://pypi.python.org/pypi/asciinema"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md doc/asciicast-v1.md )
+
+python_test() {
+       nosetests || die
+}
+
+src_install() {
+       distutils-r1_src_install
+       doman man/asciinema.1
+}