dev-python/py-cpuinfo: add py38 support and fix setuptools dep
authorTim Harder <radhermit@gentoo.org>
Mon, 3 Feb 2020 22:14:18 +0000 (15:14 -0700)
committerTim Harder <radhermit@gentoo.org>
Mon, 3 Feb 2020 22:16:16 +0000 (15:16 -0700)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
dev-python/py-cpuinfo/py-cpuinfo-5.0.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/py-cpuinfo/py-cpuinfo-5.0.0-r1.ebuild b/dev-python/py-cpuinfo/py-cpuinfo-5.0.0-r1.ebuild
new file mode 100644 (file)
index 0000000..5c32234
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Get CPU info with pure Python 2 & 3"
+HOMEPAGE="https://github.com/workhorsy/py-cpuinfo https://pypi.org/project/py-cpuinfo/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+distutils_enable_tests setup.py
+
+DOCS=( ChangeLog )