dev-python/sphinxcontrib-documentedlist: add version 0.6
authorFoster McLane <fkmclane@gmail.com>
Mon, 11 Sep 2017 12:54:01 +0000 (08:54 -0400)
committerMichał Górny <mgorny@gentoo.org>
Wed, 18 Oct 2017 15:35:27 +0000 (17:35 +0200)
Add DocumentedList Sphinx Extension version 0.6 required to generate
documentation for some pacakges, e.g. mitmproxy. This package is
intended to facilitate the net-proxy/mitmproxy package in the Pentoo
overlay.

Closes: https://github.com/gentoo/gentoo/pull/5688
Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-python/sphinxcontrib-documentedlist/Manifest [new file with mode: 0644]
dev-python/sphinxcontrib-documentedlist/metadata.xml [new file with mode: 0644]
dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinxcontrib-documentedlist/Manifest b/dev-python/sphinxcontrib-documentedlist/Manifest
new file mode 100644 (file)
index 0000000..cb692a6
--- /dev/null
@@ -0,0 +1 @@
+DIST sphinxcontrib-documentedlist-0.6.tar.gz 4983 SHA256 0ca2009a577b3e3b2a5dabef8c0e2d5067be8ffda84f893ca356a8a9784fc21a SHA512 9d7f14400b2a3e9b96f01ac003f70c0f7112d9286b2a978495f3089fe94137b034835bd91944e5709fb22553c30c9c324558c9a38ae82b932e1f2ba7f6927dd9 WHIRLPOOL d661d2016a777aea218ed352f64dae706edc326bae1d5fdd47a97368d394bfa883f45765f5ac05aed232f212703348ef5cbe3c908c2dbf461803a328acf7de1c
diff --git a/dev-python/sphinxcontrib-documentedlist/metadata.xml b/dev-python/sphinxcontrib-documentedlist/metadata.xml
new file mode 100644 (file)
index 0000000..02a776f
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>fkmclane@gmail.com</email>
+    <name>Foster McLane</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>proxy-maint@gentoo.org</email>
+    <name>Proxy Maintainers</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="pypi">sphinxcontrib-documentedlist</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild b/dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild
new file mode 100644 (file)
index 0000000..b55b801
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to convert a Python list into a generated table"
+HOMEPAGE="https://github.com/chintal/sphinxcontrib-documentedlist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+       dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+       distutils-r1_python_install_all
+       find "${ED}" -name '*.pth' -delete || die
+}