dev-perl/Apache-SizeLimit: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Tue, 28 Apr 2020 08:03:51 +0000 (20:03 +1200)
committerKent Fredric <kentnl@gentoo.org>
Tue, 28 Apr 2020 08:04:37 +0000 (20:04 +1200)
- Correct LICENSE
- Strip unwanted tests
- Ensure dependencies to make more tests work
- Parallel Testing Enabled

Dropped keywords:
- alpha arm ppc ppc64 x86
- due to new dependency dev-perl/Linux-Smaps

Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Apache-SizeLimit/Apache-SizeLimit-0.970.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Apache-SizeLimit/Apache-SizeLimit-0.970.0-r2.ebuild b/dev-perl/Apache-SizeLimit/Apache-SizeLimit-0.970.0-r2.ebuild
new file mode 100644 (file)
index 0000000..1c85a20
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PHRED
+DIST_VERSION=0.97
+inherit perl-module
+
+DESCRIPTION="Graceful exit for large children"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PERL_RM_FILES=(
+       t/pod.t
+)
+# mod_perl < 2.0.5 bundles Apache-SizeLimit
+RDEPEND="dev-perl/Linux-Pid
+       !<www-apache/mod_perl-2.0.5
+       >=www-apache/mod_perl-2.0.5"
+BDEPEND="${RDEPEND}
+       test? (
+               dev-perl/Linux-Smaps
+               >=dev-perl/Apache-Test-1.360.0
+               !www-apache/mpm_itk
+       )
+"