New upstream version. Clean old ebuilds for the 1.4.4 branch.
authorFernando J. Pereda <ferdy@gentoo.org>
Thu, 7 Dec 2006 15:36:19 +0000 (15:36 +0000)
committerFernando J. Pereda <ferdy@gentoo.org>
Thu, 7 Dec 2006 15:36:19 +0000 (15:36 +0000)
Package-Manager: portage-2.1.1-r2

dev-util/git/ChangeLog
dev-util/git/files/digest-git-1.4.4.2 [new file with mode: 0644]
dev-util/git/git-1.4.4.2.ebuild [new file with mode: 0644]

index 24df258469dcb0621e8b1c0b05ee159fc6e11aed..18427da31d1c9eaf09ea89f4b88fb84d6dbf76f7 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-util/git
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.147 2006/11/26 14:01:48 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.148 2006/12/07 15:36:19 ferdy Exp $
+
+*git-1.4.4.2 (07 Dec 2006)
+
+  07 Dec 2006; Fernando J. Pereda <ferdy@gentoo.org> -git-1.4.4.ebuild,
+  -git-1.4.4.1.ebuild, +git-1.4.4.2.ebuild:
+  New upstream version. Clean old ebuilds for the 1.4.4 branch.
 
 *git-1.4.4.1 (26 Nov 2006)
 
diff --git a/dev-util/git/files/digest-git-1.4.4.2 b/dev-util/git/files/digest-git-1.4.4.2
new file mode 100644 (file)
index 0000000..e071edd
--- /dev/null
@@ -0,0 +1,9 @@
+MD5 c4f72d96f62ae97c6e8d5cdb4afd55ca git-1.4.4.2.tar.bz2 887999
+RMD160 8b1892f630eadbe88223b338b4cce7118afbedcf git-1.4.4.2.tar.bz2 887999
+SHA256 907138a7537ff8cef5a9bb258cbba3e32fa46b240f66cd16d5bf530e081ac6b9 git-1.4.4.2.tar.bz2 887999
+MD5 ccf58cfe1608617e555c32d274a2c99c git-htmldocs-1.4.4.2.tar.bz2 325578
+RMD160 0c9c1ffb89e25566002f0af5c6c5d829081a5dc0 git-htmldocs-1.4.4.2.tar.bz2 325578
+SHA256 c1b2b32816122dfe47a588cba50aaa823f307e5d4935ed6c80261762bfa44b6a git-htmldocs-1.4.4.2.tar.bz2 325578
+MD5 27a9192d91af69ae27691e360649cd7d git-manpages-1.4.4.2.tar.bz2 104745
+RMD160 b55d9da2ecf3862495408e4b01a9d3f1f2d51c36 git-manpages-1.4.4.2.tar.bz2 104745
+SHA256 e4685c50c8e79bb7166ae63578f70933b518dd5850d27cfa331fae3c0032aa16 git-manpages-1.4.4.2.tar.bz2 104745
diff --git a/dev-util/git/git-1.4.4.2.ebuild b/dev-util/git/git-1.4.4.2.ebuild
new file mode 100644 (file)
index 0000000..ee832ed
--- /dev/null
@@ -0,0 +1,155 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.4.2.ebuild,v 1.1 2006/12/07 15:36:19 ferdy Exp $
+
+inherit python toolchain-funcs eutils elisp-common perl-module bash-completion
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+               mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+               doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc elibc_uclibc emacs gtk mozsha1 ppcsha1 tk webdav"
+
+DEPEND="dev-libs/openssl
+               sys-libs/zlib
+               !app-misc/git
+               curl? ( net-misc/curl )
+               webdav? ( dev-libs/expat )
+               emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+               dev-lang/perl
+               >=dev-lang/python-2.3
+               app-text/rcs
+               tk? ( dev-lang/tk )
+               gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+       local myopts
+
+       if use mozsha1 ; then
+               myopts="${myopts} MOZILLA_SHA1=YesPlease"
+       elif use ppcsha1 ; then
+               myopts="${myopts} PPC_SHA1=YesPlease"
+       fi
+
+       if use curl ; then
+               use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+       else
+               myopts="${myopts} NO_CURL=YesPlease"
+               use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+       fi
+
+       myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+       # Older python versions need own subproccess.py
+       python_version
+       [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+       use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+       export MY_MAKEOPTS=${myopts}
+}
+
+showpkgdeps() {
+       local pkg=$1
+       shift
+       einfo "  $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       sed -i \
+               -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+               -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+               -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+               -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+               Makefile || die "sed failed"
+
+       exportmakeopts
+}
+
+src_compile() {
+       emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+       if use emacs ; then
+               elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+       fi
+}
+
+src_install() {
+       emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+       use tk || rm "${D}"/usr/bin/gitk
+
+       doman "${WORKDIR}"/man?/*
+
+       dodoc README COPYING Documentation/SubmittingPatches
+       if use doc ; then
+               dodoc Documentation/technical/*
+               dodir /usr/share/doc/${PF}/html
+               cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+       fi
+
+       dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+       if use emacs ; then
+               insinto "${SITELISP}"
+               doins contrib/emacs/{,vc-}git.el*
+               elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+       fi
+
+       if use gtk ; then
+               dobin contrib/gitview/gitview
+               use doc && dodoc contrib/gitview/gitview.txt
+       fi
+
+       insinto /etc/xinetd.d
+       newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+       newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+       newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+       fixlocalpod
+}
+
+src_test() {
+       cd "${S}"
+
+       has_version dev-util/subversion || \
+               MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+       has_version app-arch/unzip || \
+               rm "${S}"/t/t5000-tar-tree.sh
+       use amd64 && \
+               rm "${S}"/t/t9200-git-cvsexportcommit.sh
+       emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+       einfo "These additional scripts need some dependencies:"
+       einfo
+       showpkgdeps git-archimport "dev-util/tla"
+       showpkgdeps git-cvsimport ">=dev-util/cvsps-2.1"
+       showpkgdeps git-svnimport "dev-util/subversion(USE=perl)"
+       showpkgdeps git-svn "dev-util/subversion(USE=perl)" "dev-perl/libwww-perl"
+       showpkgdeps git-quiltimport "dev-util/quilt"
+       showpkgdeps git-cvsserver "dev-perl/DBI" "dep-perl/DBD-SQLite"
+       einfo
+}
+
+pkg_postrm() {
+       # regenerate site-gentoo if we are merged USE=emacs and unmerged
+       # USE=-emacs
+       has_version virtual/emacs && elisp-site-regen
+}