dev-haskell/http-common: new package, a depend of snap-server-1
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:14:15 +0000 (21:14 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:57:02 +0000 (21:57 +0000)
Common types for HTTP clients and servers

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/http-common/Manifest [new file with mode: 0644]
dev-haskell/http-common/http-common-0.8.2.0.ebuild [new file with mode: 0644]
dev-haskell/http-common/metadata.xml [new file with mode: 0644]

diff --git a/dev-haskell/http-common/Manifest b/dev-haskell/http-common/Manifest
new file mode 100644 (file)
index 0000000..d33b035
--- /dev/null
@@ -0,0 +1 @@
+DIST http-common-0.8.2.0.tar.gz 9473 SHA256 2915e77b0d000a617d4c1304fdc46f45b70acc0942670066a95b2c8d4e504593 SHA512 e02e9b08235483220856ed1cacebea1910ec41451d7ec68b86a2193f5c050f74ef3747a4a2c35c560795727d9f62ee6485cfd1ed5597fb7645ce6339f969851a WHIRLPOOL a30b8cd009f4e20a63a9c041e1779f3d7aa4b0d5ce18770a8b2c513e22de0107daba09c3f8d008f67bbf394b7d513d10d031baadb5948d5428eb25c08d312cf5
diff --git a/dev-haskell/http-common/http-common-0.8.2.0.ebuild b/dev-haskell/http-common/http-common-0.8.2.0.ebuild
new file mode 100644 (file)
index 0000000..e3057b1
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Common types for HTTP clients and servers"
+HOMEPAGE="http://research.operationaldynamics.com/projects/http-streams/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/base64-bytestring:=[profile?]
+       dev-haskell/blaze-builder:=[profile?]
+       dev-haskell/case-insensitive:=[profile?]
+       dev-haskell/mtl:=[profile?]
+       dev-haskell/network:=[profile?]
+       dev-haskell/text:=[profile?]
+       dev-haskell/transformers:=[profile?]
+       dev-haskell/unordered-containers:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.10
+"
diff --git a/dev-haskell/http-common/metadata.xml b/dev-haskell/http-common/metadata.xml
new file mode 100644 (file)
index 0000000..9b125c8
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               /Overview/
+               
+               Base types used by a variety of HTTP clients and servers. See http-streams
+               "Network.Http.Client" or pipes-http "Pipes.Http.Client" for full
+               documentation. You can import @Network.Http.Types@ if you like, but both
+               http-streams and pipes-http re-export this package's types and functions.
+       </longdescription>
+</pkgmetadata>