sys-libs/uclibc: git-2->git-r3, explicit EAPI=0
authorMarty E. Plummer <hanetzer@startmail.com>
Fri, 27 Apr 2018 17:38:46 +0000 (12:38 -0500)
committerAnthony G. Basile <blueness@gentoo.org>
Fri, 27 Apr 2018 22:11:15 +0000 (18:11 -0400)
Also unified the live vs versioned ebuild logic.

Package-Manager: Portage-2.3.31, Repoman-2.3.9
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
sys-libs/uclibc/uclibc-0.9.33.9999.ebuild
sys-libs/uclibc/uclibc-9999.ebuild

index 32bb541808547dee5a5b64fbfc98dc6c6caaec4d..4c712c8a69a84f580d13973903309852a93cf5be 100644 (file)
@@ -1,10 +1,20 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
+EAPI=0
+
 inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="git://git.busybox.net/uClibc"
-       inherit git-2
+
+MY_P=uClibc-${PV}
+if [[ ${PV} == *9999* ]] ; then
+       EGIT_REPO_URI="https://git.busybox.net/uClibc"
+       EGIT_BRANCH="0.9.33"
+       inherit git-r3
+else
+       PATCH_VER="17"
+       SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
+               ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
+       KEYWORDS="-* amd64 arm m68k ~mips ppc sh sparc x86"
 fi
 
 export CBUILD=${CBUILD:-${CHOST}}
@@ -15,15 +25,8 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
        fi
 fi
 
-MY_P=uClibc-${PV}
 DESCRIPTION="C library for developing embedded Linux systems"
 HOMEPAGE="https://www.uclibc.org/"
-if [[ ${PV} != "9999" ]] ; then
-       PATCH_VER="17"
-       SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
-               ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
-       KEYWORDS="-* amd64 arm m68k ~mips ppc sh sparc x86"
-fi
 
 LICENSE="LGPL-2"
 SLOT="0"
@@ -232,8 +235,8 @@ src_config() {
 }
 
 src_unpack() {
-       if [[ ${PV} == "9999" ]] ; then
-               git-2_src_unpack
+       if [[ ${PV} == *9999* ]] ; then
+               git-r3_src_unpack
        else
                unpack ${A}
        fi
index fbc8a60a1fc9373454ff0f14a9f531d71a3e92ff..d55f0afff6dab9a1b6a0ca0ed24d486946a44bb6 100644 (file)
@@ -1,11 +1,20 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
+EAPI=0
+
 inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
-if [[ ${PV} == *9999 ]] ; then
+
+MY_P=uClibc-${PV}
+if [[ ${PV} == *9999* ]] ; then
+       EGIT_REPO_URI="https://git.busybox.net/uClibc"
        EGIT_BRANCH="0.9.33"
-       EGIT_REPO_URI="git://git.busybox.net/uClibc"
-       inherit git-2
+       inherit git-r3
+else
+       PATCH_VER=""
+       SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
+               ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
+       KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
 fi
 
 export CBUILD=${CBUILD:-${CHOST}}
@@ -16,15 +25,8 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
        fi
 fi
 
-MY_P=uClibc-${PV}
 DESCRIPTION="C library for developing embedded Linux systems"
 HOMEPAGE="https://www.uclibc.org/"
-if [[ ${PV} != *9999 ]] ; then
-       PATCH_VER=""
-       SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
-               ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
-       KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
-fi
 
 LICENSE="LGPL-2"
 SLOT="0"
@@ -231,8 +233,8 @@ src_config() {
 }
 
 src_unpack() {
-       if [[ ${PV} == *9999 ]] ; then
-               git-2_src_unpack
+       if [[ ${PV} == *9999* ]] ; then
+               git-r3_src_unpack
        else
                unpack ${A}
        fi
index f5cec3749e759f637b10753f11804e2b025b68f9..3e096317babc2f315b6fc1ac83be857859ea057b 100644 (file)
@@ -1,10 +1,19 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
+EAPI=0
+
 inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="git://git.busybox.net/uClibc"
-       inherit git-2
+
+MY_P=uClibc-${PV}
+if [[ ${PV} == *9999* ]] ; then
+       EGIT_REPO_URI="https://git.busybox.net/uClibc"
+       inherit git-r3
+else
+       PATCH_VER=""
+       SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
+               ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
+       KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
 fi
 
 export CBUILD=${CBUILD:-${CHOST}}
@@ -15,15 +24,8 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
        fi
 fi
 
-MY_P=uClibc-${PV}
 DESCRIPTION="C library for developing embedded Linux systems"
 HOMEPAGE="https://www.uclibc.org/"
-if [[ ${PV} != "9999" ]] ; then
-       PATCH_VER=""
-       SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
-               ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
-       KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
-fi
 
 LICENSE="LGPL-2"
 SLOT="0"
@@ -230,8 +232,8 @@ src_config() {
 }
 
 src_unpack() {
-       if [[ ${PV} == "9999" ]] ; then
-               git-2_src_unpack
+       if [[ ${PV} == *9999* ]] ; then
+               git-r3_src_unpack
        else
                unpack ${A}
        fi