Fix broken autotools handling.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 14:49:02 +0000 (14:49 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 14:49:02 +0000 (14:49 +0000)
Package-Manager: portage-2.1.2_rc4-r5

dev-tcltk/otcl/ChangeLog
dev-tcltk/otcl/otcl-1.11.ebuild
dev-tcltk/tclcl/ChangeLog
dev-tcltk/tclcl/tclcl-1.17.ebuild

index d6474a19f2c29f665fb00dc3c0df8257d7371def..403e91b3af35eb014c7d306bd16a57e8182c3876 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-tcltk/otcl
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/ChangeLog,v 1.24 2006/08/06 16:39:44 weeve Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/ChangeLog,v 1.25 2007/01/04 14:47:26 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> otcl-1.11.ebuild:
+  Fix broken autotools handling.
 
   06 Aug 2006; Jason Wever <weeve@gentoo.org> otcl-1.11.ebuild:
   Stable on SPARC wrt bug #123209.
index 184e30e1bd8ec9663af497a80c5d34e9b77c1a5b..115f27e6653ebc50a70310367b1f89b5ee2f20de 100644 (file)
@@ -1,6 +1,9 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/otcl-1.11.ebuild,v 1.4 2006/08/06 16:39:44 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/otcl-1.11.ebuild,v 1.5 2007/01/04 14:47:26 flameeyes Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
 
 inherit eutils autotools virtualx
 
@@ -25,10 +28,8 @@ src_unpack() {
        EPATCH_OPTS="-p1 -d${S}" epatch ${FILESDIR}/otcl-1.11-badfreefix.patch
        EPATCH_OPTS="-p1 -d${S}" epatch ${FILESDIR}/otcl-1.11-configure-cleanup.patch
 
-       cd ${S}
-       eautoconf
-       elibtoolize
-       libtoolize -f
+       cd "${S}"
+       eautoreconf
 }
 
 src_compile() {
@@ -41,7 +42,7 @@ src_compile() {
        echo myconf $myconf
        econf ${myconf} || die "econf failed"
        emake all || die "emake all failed"
-       emake libotcl.so || die  "emake libotcl.so failed"
+       emake libotcl.so || die  "emake libotcl.so failed"
 }
 
 src_install() {
index f9b3a4d835a327a6b2650bdfd9c2e385f6800888..63055f614e5d79872d0dff0dc353a75eb06de1e2 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-tcltk/tclcl
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclcl/ChangeLog,v 1.12 2006/05/15 17:13:54 robbat2 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclcl/ChangeLog,v 1.13 2007/01/04 14:49:02 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> tclcl-1.17.ebuild:
+  Fix broken autotools handling.
 
 *tclcl-1.17 (15 May 2006)
 
index 530b4605527d8132977794834c8c12fee93b36dc..b841b869c6e35a0d9f1773eea4b6fbf99d5b1048 100644 (file)
@@ -1,6 +1,9 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclcl/tclcl-1.17.ebuild,v 1.1 2006/05/15 17:13:54 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclcl/tclcl-1.17.ebuild,v 1.2 2007/01/04 14:49:02 flameeyes Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
 
 inherit eutils autotools
 
@@ -22,10 +25,8 @@ src_unpack() {
        unpack ${A}
        EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-1.16-http.patch
        EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-1.17-configure-cleanup.patch
-       cd ${S}
-       eautoconf
-       elibtoolize
-       libtoolize -f
+       cd "${S}"
+       eautoreconf
 }
 
 src_compile() {