app-i18n/ibus-typing-booster: new upstream release
authorAkinori Hattori <hattya@gentoo.org>
Sat, 16 May 2020 13:40:55 +0000 (22:40 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sat, 16 May 2020 13:40:55 +0000 (22:40 +0900)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-i18n/ibus-typing-booster/Manifest
app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.3.ebuild [new file with mode: 0644]

index cabeed7662bd06ef74d6d32562644a26bb22bc27..c46154dd0879bf7bc3849b3e0a23be766a9184d4 100644 (file)
@@ -1,2 +1,3 @@
 DIST ibus-typing-booster-2.8.0.tar.gz 8018809 BLAKE2B 9306b980623094a8b72d6824292d8d52a90df69b7f1f7df11c0df63c5d2c4f2aa1ca4e2765320096915b30cc807fbe24f64a219c3beb1bec4a1d81be4511779a SHA512 64c112275ec63ac3d3c13202256be8bfded152da7b08dde7e6eb01dd38fd48535d63daaa6c2fcc09e64dcd4927931380ccd0a0be739f04330fb15dc0d4fe1823
 DIST ibus-typing-booster-2.8.2.tar.gz 8161995 BLAKE2B 79c7bacb7c5a07139c710ddf063b58ed6bc15d1f58529dfaa0d8f1935cb513fe27ad5e95af0ca7383922f5642d1197cf74183ba2463a3fa81637add5d8376691 SHA512 3dffc21aae59ebc8c7b3ef3df588f958b4a42a2025dc6a82613e9bb1b324f8c999d01b8d98ed48794b3ea8fd5c3221df489a88f8c54c154a69be9908beda85b5
+DIST ibus-typing-booster-2.8.3.tar.gz 8184044 BLAKE2B 06b7bc3c39f8c135d5e6d2c90ceaa2df8c38041cb4cc7d583cc335bb3bbdbf4915a6bcb0fff80bbaae797e8bda74bed26077ab4739a8f9584ecfaade833eefbb SHA512 18cee36b5f5c3d6da1cb455e785317c0e2b9826e49e3b2655f4f7a3fce4bdd279ff24614083559996031876702879530799a709e196dc5d68345f0d942972dff
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.3.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.3.ebuild
new file mode 100644 (file)
index 0000000..ed1abe7
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+       dev-libs/m17n-lib
+       $(python_gen_cond_dep '
+               app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+               dev-python/pyenchant[${PYTHON_MULTI_USEDEP}]
+               dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+               dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+       ')"
+RDEPEND="${DEPEND}
+       >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+       virtual/pkgconfig"
+
+pkg_preinst() {
+       xdg_pkg_preinst
+       gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}