gnome-base/nautilus: bump to 3.34.3, drop USE=packagekit
authorMart Raudsepp <leio@gentoo.org>
Fri, 24 Apr 2020 20:25:56 +0000 (23:25 +0300)
committerMart Raudsepp <leio@gentoo.org>
Fri, 24 Apr 2020 20:27:22 +0000 (23:27 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-base/nautilus/Manifest
gnome-base/nautilus/nautilus-3.34.3.ebuild [new file with mode: 0644]

index 5928b3e7fc0d36d2bc3d219b9fb537bf9f78dccf..1b090e9c869394532783676dfab443b66d042092 100644 (file)
@@ -1,2 +1,3 @@
 DIST nautilus-3.32.3.tar.xz 3197820 BLAKE2B 28140210a855fe62faba4f0833067a81c4d8f71c0cc870ba4fdcc016754b01df003e45f636836f67cced8515aba8c8fb7922de788a14bfe0f0cc4518010aed5f SHA512 f19710f02bd91edb2d2f6cb8f46be6bebea3edfed14a07612444d5990533bafd032b604d65533727eb377b574d6bd4c82dbe11894d85ad254ee1473b683c4392
 DIST nautilus-3.34.2.tar.xz 3196976 BLAKE2B 38424061cb5591fc1df5824dd80e282637345bde148955c81632d4894153e10f3840389bb4e43dffe8c28f10eb6e64c1cc89f1bffdcf80fa581a5d47b7724dee SHA512 1a4e24fea3201f68b0316b95425bbc90078baa1ae7dccef2d2e48beda4007ecf2986254cde243d310c548e47a4693d84d1255654199649ce08429a99fb3a3a51
+DIST nautilus-3.34.3.tar.xz 3213260 BLAKE2B a417ee5d5e032befed704b71b9ffd29cc9a2a6fae0612f96601756b876b0990625cc78eb2c7679bdce914f3dd30208b60243f403a508cf87a6761ea56251140d SHA512 f8ef86b5b67ef2b8eced492ee6b8d77155a9d6ec5ba6bb18132d678e6f12870963da9bcf4ff0bfbb8f4791bf068314557f9551febc23234c48d722e529c6ed9d
diff --git a/gnome-base/nautilus/nautilus-3.34.3.ebuild b/gnome-base/nautilus/nautilus-3.34.3.ebuild
new file mode 100644 (file)
index 0000000..1c66ba5
--- /dev/null
@@ -0,0 +1,106 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 virtualx xdg
+
+DESCRIPTION="Default file manager for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Nautilus"
+
+LICENSE="GPL-3+ LGPL-2.1+"
+SLOT="0"
+IUSE="gnome +gstreamer gtk-doc +introspection +previewer selinux sendto"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+       >=dev-libs/glib-2.58.1:2
+       >=media-libs/gexiv2-0.10.0
+       gstreamer? ( media-libs/gstreamer:1.0
+               media-libs/gst-plugins-base:1.0 )
+       >=app-arch/gnome-autoar-0.2.1
+       >=gnome-base/gnome-desktop-3.0.0:3=
+       >=x11-libs/gtk+-3.22.27:3[X,introspection?]
+       >=x11-libs/pango-1.28.3
+       selinux? ( >=sys-libs/libselinux-2.0 )
+       >=app-misc/tracker-2.0:=
+       x11-libs/libX11
+       >=dev-libs/libxml2-2.7.8:2
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+       sendto? ( !<gnome-extra/nautilus-sendto-3.0.1 )
+       gstreamer? ( !<media-video/totem-3.31.91[nautilus] )
+       >=app-misc/tracker-miners-2.0:=
+" # uses org.freedesktop.Tracker.Miner.Files gsettings schema from tracker-miners
+BDEPEND="
+       >=dev-util/gdbus-codegen-2.51.2
+       dev-util/glib-utils
+       gtk-doc? (
+               >=dev-util/gtk-doc-1.10
+               app-text/docbook-xml-dtd:4.1.2 )
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       x11-base/xorg-proto
+"
+PDEPEND="
+       gnome? ( x11-themes/adwaita-icon-theme )
+       previewer? ( >=gnome-extra/sushi-0.1.9 )
+       sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
+       >=gnome-base/gvfs-1.14[gtk(+)]
+" # Need gvfs[gtk] for recent:/// support; always built (without USE=gtk) since gvfs-1.34
+
+PATCHES=(
+       "${FILESDIR}"/3.30.5-docs-build.patch # Always install pregenerated manpage, keeping docs option for gtk-doc
+       "${FILESDIR}"/3.32.3-optional-gstreamer.patch # Allow controlling audio-video-properties build
+       "${FILESDIR}"/3.34.2-pango-1.42-compat.patch
+)
+
+src_prepare() {
+       if use previewer; then
+               DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files.
+                       To activate the previewer, select a file and press space; to
+                       close the previewer, press space again."
+       fi
+       xdg_src_prepare
+}
+
+src_configure() {
+       local emesonargs=(
+               $(meson_use gtk-doc docs)
+               -Dextensions=true # image file properties, sendto support; also required for -Dgstreamer=true
+               $(meson_use gstreamer) # gstreamer audio-video-properties extension
+               $(meson_use introspection)
+               -Dpackagekit=false
+               $(meson_use selinux)
+               -Dprofiling=false
+               -Dtests=$(usex test all none)
+       )
+       meson_src_configure
+}
+
+src_install() {
+       use previewer && readme.gentoo_create_doc
+       meson_src_install
+}
+
+src_test() {
+       virtx meson_src_test
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+
+       if use previewer; then
+               readme.gentoo_print_elog
+       else
+               elog "To preview media files, emerge nautilus with USE=previewer"
+       fi
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}