projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0d69c92
)
dev-python/pip: Resolve circular deps,
author
Justin Lecher
<jlec@gentoo.org>
Thu, 27 Aug 2015 07:58:56 +0000
(09:58 +0200)
committer
Justin Lecher
<jlec@gentoo.org>
Thu, 27 Aug 2015 07:58:56 +0000
(09:58 +0200)
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=558808
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/pip/pip-7.1.2.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/pip/pip-7.1.2.ebuild
b/dev-python/pip/pip-7.1.2.ebuild
index 1a0c9d3b032f0fdc86524982f6881b6b2751eb90..2c47eb85bba826ed9156213d7e3dcbfc4a266331 100644
(file)
--- a/
dev-python/pip/pip-7.1.2.ebuild
+++ b/
dev-python/pip/pip-7.1.2.ebuild
@@
-30,10
+30,12
@@
VENDOR_DEPEND="
>=dev-python/packaging-15.3[${PYTHON_USEDEP}]
>=dev-python/retrying-1.3.3[${PYTHON_USEDEP}]
"
-RDEPEND="
${VENDOR_DEPEND}
+RDEPEND="
>=dev-python/setuptools-18.2[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+# circular #558808
+PDEPEND="${VENDOR_DEPEND}"
# required test data isn't bundled with the tarball
RESTRICT="test"