app-admin/ansible: 2.7.12 and 2.8.2 bump with 2.6 cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 5 Jul 2019 14:08:38 +0000 (09:08 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 5 Jul 2019 14:09:34 +0000 (09:09 -0500)
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-admin/ansible/Manifest
app-admin/ansible/ansible-2.7.12.ebuild [moved from app-admin/ansible/ansible-2.6.17.ebuild with 94% similarity]
app-admin/ansible/ansible-2.8.2.ebuild [new file with mode: 0644]

index 4167e9e703e6590b4ca7f4fb32ef4bde62eb85d4..812ff5c451dc8322d624eb5c42d1b93fd4c36586 100644 (file)
@@ -1,3 +1,4 @@
-DIST ansible-2.6.17.tar.gz 10742849 BLAKE2B 04667612ab7d149d7a322ce674c2256164c0d958d3e5b34cafeba0b90d4f0f07ee95a31bf0c205c13c90ee4d63c3045ce2fc51de8996a7dcb877d39e2da680f5 SHA512 ba46192549be3e853232d865116c176aebd8ed2b63fcbb45cb633d3809fc534004849a70a2abad80f9fe99deeb55af3883ce1bfe0db4a9afd2f6b8045936e860
 DIST ansible-2.7.11.tar.gz 11855636 BLAKE2B 3de8fa1287655f778b1d9036bf78a91387cf238209eb2bfd17ee79f7d77a2e03ae734901bdc04226d635b3d8543d122aaa251107befab8cc4a4fc63cfcd8deec SHA512 06f805a701f8284ac1a65251b9358cf6f27d420aabb1e29298f9e4d8aa73251bd4a8e8a3981f744b97b2f750fd3b594a9b505e5baa3ff2cb3aa7a37603ba48fa
+DIST ansible-2.7.12.tar.gz 11860944 BLAKE2B 52cc79a88bbff9dc009ead8ab9f9d299420ae060e211aab23fe3bbef8c8229cd9e526dc3df518a4285cc17c1448ab4892cc3059d70bfef2fd332a44c72b57019 SHA512 0ab68af8239f6d4d2a13bd38a09fe6f3c700231e7c83df0af77c70ea62faebd0d45e1ff316963c6c72931608d49a79b98e8d3ddc6f4c8b826aabe87dc71cc6f9
 DIST ansible-2.8.1.tar.gz 14299403 BLAKE2B defbe8fa8db7ab3325cf57df3bdfe901f53544b4c1b6460cefbfa9393acfe2a0e104f99468ad8e907d90d33842563bd7ab666d30f64572fd146c7ce46ff77048 SHA512 08be80584edfe28f11fe750735ade117deaf3a7c98fe15fb2fa0e3a5ed0c3f98cd126b60386e51d15ce275e8f1fc3eda0177bb56e0823b2f2b7702cc0e35be92
+DIST ansible-2.8.2.tar.gz 14328267 BLAKE2B 9548af73914b68374f71ab83e5a68e86e75b8ccf86066831699b147091d067a3f1e0b59d94b22b42151d90779f6d3bb39856a3d205862c933aec6bbe76824e22 SHA512 02cd8fd214f61041914abeebf2395f16acf370e110bdef0181689f604f06504902f9a05a2413877a31680528af539f078e2cd7b7f2eebe2389c9aa441b063305
similarity index 94%
rename from app-admin/ansible/ansible-2.6.17.ebuild
rename to app-admin/ansible/ansible-2.7.12.ebuild
index 90340deaacc1a773e5c57686d910d9777f2a2719..63e11740ae9cfe92b74dae202dd39078037a423b 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 
 inherit distutils-r1 eutils
 
@@ -13,7 +13,7 @@ SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
 
 LICENSE="GPL-3"
 SLOT="0"
-KEYWORDS="amd64 x86 ~x64-macos"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
 IUSE="doc test"
 
 RDEPEND="
diff --git a/app-admin/ansible/ansible-2.8.2.ebuild b/app-admin/ansible/ansible-2.8.2.ebuild
new file mode 100644 (file)
index 0000000..e6b530d
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+       dev-python/paramiko[${PYTHON_USEDEP}]
+       dev-python/jinja[${PYTHON_USEDEP}]
+       dev-python/pyyaml[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/cryptography[${PYTHON_USEDEP}]
+       dev-python/httplib2[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       dev-python/netaddr[${PYTHON_USEDEP}]
+       net-misc/sshpass
+       virtual/ssh
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? (
+               ${RDEPEND}
+               dev-python/nose[${PYTHON_USEDEP}]
+               >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+               dev-python/passlib[${PYTHON_USEDEP}]
+               dev-python/coverage[${PYTHON_USEDEP}]
+               dev-python/unittest2[${PYTHON_USEDEP}]
+               dev-vcs/git
+       )"
+
+python_compile_all() {
+       if use doc; then
+               cd docs/docsite || die
+               export CPUS=4
+               emake -f Makefile.sphinx html
+       fi
+}
+
+python_prepare_all() {
+       rm -fv MANIFEST.in || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+       distutils-r1_python_install_all
+
+       dodoc -r examples
+}