media-sound/mp3wrap: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 17 Oct 2019 09:00:03 +0000 (11:00 +0200)
committerDavid Seifert <soap@gentoo.org>
Thu, 17 Oct 2019 09:00:03 +0000 (11:00 +0200)
Bug: https://bugs.gentoo.org/697274
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/mp3wrap/files/mp3wrap-0.5-Wimplicit-function-declaration.patch [new file with mode: 0644]
media-sound/mp3wrap/mp3wrap-0.5.ebuild

diff --git a/media-sound/mp3wrap/files/mp3wrap-0.5-Wimplicit-function-declaration.patch b/media-sound/mp3wrap/files/mp3wrap-0.5-Wimplicit-function-declaration.patch
new file mode 100644 (file)
index 0000000..2398122
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/wrap.c
++++ b/wrap.c
+@@ -26,6 +26,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <strings.h>
++#include <string.h>
+ #include "wrap.h"
+ #include "mp3wrap.h"
index eed1cd4354b387181f1247d40721061bbe4167a6..c0f1e36d268fc75cdc05d2c4777f90aff8d3f65c 100644 (file)
@@ -1,23 +1,22 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-DESCRIPTION="Command-line utility that wraps quickly two or more mp3 files in one single large playable mp3"
+DESCRIPTION="Command-line utility that wraps multiple mp3 files into one large playable mp3"
 SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
 HOMEPAGE="http://mp3wrap.sourceforge.net/"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ~ppc sparc x86"
-IUSE=""
 
-RDEPEND=""
-DEPEND=""
+PATCHES=( "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch )
 
 src_install() {
-       dobin mp3wrap || die "dobin failed"
+       dobin mp3wrap
+
        doman mp3wrap.1
-       dodoc AUTHORS ChangeLog README
-       dohtml doc/*.html
+       local HTML_DOCS=( doc/*.html )
+       einstalldocs
 }