media-fonts/shinonome: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 19:48:07 +0000 (21:48 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 19:48:07 +0000 (21:48 +0200)
Bug: https://bugs.gentoo.org/697292
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
media-fonts/shinonome/shinonome-0.9.11.ebuild

index 1a05e6cfaefcd71748472476c25000fda9e8fa6d..dbb420925c3ed869ff3fbb39b5414876d659ab83 100644 (file)
@@ -1,35 +1,35 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit font
 
-IUSE=""
-
 DESCRIPTION="Japanese bitmap fonts for X"
-SRC_URI="http://openlab.jp/efont/dist/shinonome/${P}.tar.bz2"
 HOMEPAGE="http://openlab.jp/efont/shinonome/"
+SRC_URI="http://openlab.jp/efont/dist/shinonome/${P}.tar.bz2"
 
 LICENSE="public-domain"
-SLOT=0
+SLOT="0"
 KEYWORDS="alpha amd64 arm ia64 ppc ppc64 s390 sh sparc x86"
+# Only installs fonts
+RESTRICT="strip binchecks"
 
-DEPEND="x11-apps/bdftopcf"
-RDEPEND=""
+BDEPEND="x11-apps/bdftopcf"
 
-FONT_SUFFIX="pcf.gz"
-FONT_S=${S}
 DOCS="AUTHORS BUGS ChangeLog* DESIGN* INSTALL LICENSE README THANKS TODO"
+FONT_S="${S}"
+FONT_SUFFIX="pcf.gz"
 
-# Only installs fonts
-RESTRICT="strip binchecks"
+src_configure() {
+       econf --with-pcf --without-bdf
+}
 
-src_compile(){
-       econf --with-pcf --without-bdf || die
-       emake || die
+src_compile() {
+       default
 
-       for i in *.pcf ; do
-               gzip -9 $i
+       local i
+       for i in *.pcf; do
+               gzip -9 "${i}" || die
        done
 }