dev-python/pyclipper: Bump to 1.1.0_p3
authorPacho Ramos <pacho@gentoo.org>
Wed, 29 Apr 2020 16:46:38 +0000 (18:46 +0200)
committerPacho Ramos <pacho@gentoo.org>
Wed, 29 Apr 2020 16:46:38 +0000 (18:46 +0200)
Closes: https://bugs.gentoo.org/719884
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
dev-python/pyclipper/Manifest
dev-python/pyclipper/pyclipper-1.1.0_p3.ebuild [new file with mode: 0644]

index 95b30bfed2f83f0bd64b56ead64f77445c1b4499..c92dc0f4c841221128a9f5ec5bc985b58b408ab0 100644 (file)
@@ -1 +1,2 @@
 DIST pyclipper-1.1.0.tar.gz 53916 BLAKE2B 53b7b6609d602cdcbd8c8f4ceaed999c97e155747f7daeb630333f18fd2719040d118c8fa3d0e60a1ccd92c20aecb355ec9d4f9c22f66dc07b14a919f981f667 SHA512 53371bc2e0439f72ac4ebf96f833c4451d2b1924d7f9cddcbac79a0a6d6bd95ac1fb3fb08e3ea3fcf3ffe22cd718d31c7c528016605b275a3e80642e58546d74
+DIST pyclipper-1.1.0_p3.tar.gz 53353 BLAKE2B 1e510ab97ef98b83c763d4bc1154eb32f94bb035823ddcffef09fe32861c2384ccd6ffd29e5a31c0cabf71c801dd90d0176a68e93c6c2e2c9bff03c2be3fff33 SHA512 0b3c3f18593bafedaedf8a91411ba5d3d1c2ac55c949bca21e3a527ca0930eae5ea033a0f57337573a1106e2871a50dcb0176b959b98ad8ac58636c6d45f94a9
diff --git a/dev-python/pyclipper/pyclipper-1.1.0_p3.ebuild b/dev-python/pyclipper/pyclipper-1.1.0_p3.ebuild
new file mode 100644 (file)
index 0000000..c2a3894
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
+HOMEPAGE="https://github.com/fonttools/pyclipper"
+SRC_URI="https://github.com/fonttools/pyclipper/archive/${PV/_p/.post}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="
+       dev-python/cython[${PYTHON_USEDEP}]
+       dev-python/setuptools-git[${PYTHON_USEDEP}]
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]
+       dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest-runner[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+DEPEND=""
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}/${P/_p/.post}"
+
+src_prepare() {
+       distutils-r1_src_prepare
+       export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+}