dev-ros/ament_cmake_test: fix deps and python install
authorAlexis Ballier <aballier@gentoo.org>
Thu, 12 Dec 2019 15:39:19 +0000 (16:39 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 12 Dec 2019 15:43:53 +0000 (16:43 +0100)
Add live ebuild too

Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/ament_cmake_test/ament_cmake_test-0.8.1.ebuild
dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild [new file with mode: 0644]

index db5c3969d5666cffedba0b1e479a6118413f5851..71917fb38ace72a4839e489ee8b46f65c30551af 100644 (file)
@@ -5,32 +5,53 @@ EAPI=7
 
 PYTHON_COMPAT=( python{3_6,3_7} )
 
-inherit cmake-utils python-r1
+inherit cmake-utils python-r1 python-utils-r1
 
 ROS_PN="ament_cmake"
-DESCRIPTION="The core of the ament buildsystem in CMake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+       SRC_URI=""
+       S=${WORKDIR}/${P}/${PN}
+else
+       SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+       S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to add tests in the ament buildsystem"
 HOMEPAGE="https://github.com/ament/ament_cmake"
-SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       KEYWORDS=""
+else
+       KEYWORDS="~amd64"
+fi
 IUSE=""
 
 DEPEND="
        dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
        dev-ros/ament_cmake_python[${PYTHON_USEDEP}]
+       ${PYTHON_DEPS}
 "
 RDEPEND="${DEPEND}"
-BDEPEND="${PYTHON_DEPS}"
+BDEPEND="${DEPEND}"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
 
 src_configure() {
-       # This is a build tool that does not install python-related files
-       # ... but we need to propagate the deps and use python3 to build it.
-       local pyimpl="${PYTHON_COMPAT[0]}"
-       python_export "${pyimpl}" EPYTHON PYTHON
-       python_wrapper_setup
-       cmake-utils_src_configure
+       python_foreach_impl cmake-utils_src_configure
+}
+
+src_compile() {
+       python_foreach_impl cmake-utils_src_compile
+}
+
+src_test() {
+       python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+       python_foreach_impl cmake-utils_src_install
+       python_foreach_impl python_optimize
 }
diff --git a/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild b/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild
new file mode 100644 (file)
index 0000000..d459a75
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+       SRC_URI=""
+       S=${WORKDIR}/${P}/${PN}
+else
+       SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+       S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to add tests in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       KEYWORDS=""
+else
+       KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+       dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+       dev-ros/ament_cmake_python[${PYTHON_USEDEP}]
+       ${PYTHON_DEPS}
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+       python_foreach_impl cmake-utils_src_configure
+}
+
+src_compile() {
+       python_foreach_impl cmake-utils_src_compile
+}
+
+src_test() {
+       python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+       python_foreach_impl cmake-utils_src_install
+}