dev-python/jsmin: Modernize, py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Thu, 19 Mar 2020 06:37:13 +0000 (07:37 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 19 Mar 2020 06:40:40 +0000 (07:40 +0100)
Bug: https://bugs.gentoo.org/711808
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/jsmin/jsmin-2.2.2.ebuild

index 76dc206a48e60cca236bd19e7debc2bcee1c52d8..4a73f6c17ca08a66f7bbc3a0acb7a75801d9d185 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -16,8 +16,6 @@ IUSE=""
 LICENSE="MIT"
 SLOT="0"
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
 python_test() {
-       "${PYTHON}" -m ${PN}.test || die
+       "${EPYTHON}" -m jsmin.test -v || die "Tests failed with ${EPYTHON}"
 }