sci-biology/kalign: Modernise to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 15:48:34 +0000 (16:48 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 15:49:07 +0000 (16:49 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-biology/kalign/kalign-2.03-r2.ebuild [new file with mode: 0644]

diff --git a/sci-biology/kalign/kalign-2.03-r2.ebuild b/sci-biology/kalign/kalign-2.03-r2.ebuild
new file mode 100644 (file)
index 0000000..0693f82
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Global and progressive multiple sequence alignment"
+HOMEPAGE="http://msa.cgb.ki.se/"
+SRC_URI="mirror://debian/pool/main/k/kalign/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+       default
+       sed \
+               -e "s/\$(CFLAGS) \$(OBJECTS)/\$(LDFLAGS) &/" \
+               -i Makefile.in || die
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+       dobin ${PN}
+       einstalldocs
+}