Fix depends for bug 163244. Fix meta builds.
authorPeter Weller <welp@gentoo.org>
Tue, 23 Jan 2007 21:13:56 +0000 (21:13 +0000)
committerPeter Weller <welp@gentoo.org>
Tue, 23 Jan 2007 21:13:56 +0000 (21:13 +0000)
Package-Manager: portage-2.1.2-r1

xfce-extra/exo/ChangeLog
xfce-extra/exo/exo-0.3.2.ebuild
xfce-extra/xarchiver/ChangeLog
xfce-extra/xarchiver/xarchiver-0.4.6.ebuild

index db51a8a870a74d071bed219646f04ca60c845282..c7eab556fb01f4df43ab1568b4a5c14046147f62 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for xfce-extra/exo
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/ChangeLog,v 1.26 2007/01/22 02:12:39 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/ChangeLog,v 1.27 2007/01/23 21:08:57 welp Exp $
+
+  23 Jan 2007; Peter Weller <welp@gentoo.org> exo-0.3.2.ebuild:
+  Fix depends for bug 163244. Fix meta builds.
 
 *exo-0.3.2 (22 Jan 2007)
 
index 1d8a3960a70805ebf2b2de93491b8cf4ce43bf97..46c023b6c176bdd48019e35442912ea09922a9d0 100644 (file)
@@ -1,36 +1,32 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/exo-0.3.2.ebuild,v 1.1 2007/01/22 02:12:39 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/exo-0.3.2.ebuild,v 1.2 2007/01/23 21:08:57 welp Exp $
 
 inherit xfce44
 
 xfce44
 xfce44_extra_package
 
-DESCRIPTION="Libraries for Xfce 4 designed for application development"
+DESCRIPTION="Libraries for Xfce4"
 LICENSE="LGPL-2"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
 
 IUSE="debug doc hal libnotify python"
 
-RDEPEND="
-       >=dev-util/intltool-0.31
-       >=dev-lang/perl-5.6
+RDEPEND=">=dev-lang/perl-5.6
        dev-perl/URI
        >=dev-libs/glib-2.6.4
        >=x11-libs/gtk+-2.6
+       >=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
        >=xfce-base/xfce-mcs-manager-${XFCE_MASTER_VERSION}
        >=xfce-base/xfce-mcs-plugins-${XFCE_MASTER_VERSION}
-       doc? ( >=dev-util/gtk-doc-1.0 )
        libnotify? ( >=x11-libs/libnotify-0.4 )
        hal? ( >=sys-apps/hal-0.5 )
-       python? (
-               >=dev-lang/python-2.2
-               >=dev-python/pygtk-2.4.0
-       )"
+       python? ( >=dev-lang/python-2.2
+               >=dev-python/pygtk-2.4.0 )"
 DEPEND="${RDEPEND}
-       dev-python/pygtk
-       >=xfce-base/xfce-mcs-manager-${XFCE_MASTER_VERSION}"
+       doc? ( >=dev-util/gtk-doc-1 )
+       dev-util/intltool"
 
 XFCE_CONFIG="${XFCE_CONFIG}    $(use_enable doc gtk-doc) \
        $(use_enable python) $(use_enable libnotify notifications) \
index 6831bd2b38be53a0c01b9872090473460ffa079d..3fd5243feb79967bda8372bf6ecf7b7e324e048b 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for xfce-extra/xarchiver
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xarchiver/ChangeLog,v 1.16 2007/01/21 21:52:38 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xarchiver/ChangeLog,v 1.17 2007/01/23 21:13:56 welp Exp $
+
+  23 Jan 2007; Peter Weller <welp@gentoo.org> xarchiver-0.4.6.ebuild:
+  Fix depends for bug 163244. Fix meta builds.
 
   21 Jan 2007; Peter Weller <welp@gentoo.org> xarchiver-0.4.6.ebuild:
   Removed ace and rpm deps as are uneeded. Bug #107672
index 5baf3de30a14f6ae993c57028b6618381257eaf4..c3ed9888de762ab07bef3ec8d42e683e28b6a6ef 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xarchiver/xarchiver-0.4.6.ebuild,v 1.9 2007/01/21 21:52:38 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xarchiver/xarchiver-0.4.6.ebuild,v 1.10 2007/01/23 21:13:56 welp Exp $
 
 inherit xfce44
 
@@ -11,12 +11,12 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86"
 IUSE="7zip arj debug lha rar zip"
 
-DEPEND="dev-util/intltool
-       >=x11-libs/gtk+-2.6
-       >=dev-libs/glib-2.6"
-RDEPEND="${DEPEND}
+RDEPEND=">=x11-libs/gtk+-2.6
+       >=dev-libs/glib-2.6
        zip? ( app-arch/unzip app-arch/zip )
        rar? ( || ( app-arch/rar app-arch/unrar ) )
        7zip? ( app-arch/p7zip )
        arj? ( || ( app-arch/arj app-arch/unarj ) )
        lha? ( app-arch/lha )"
+DEPEND="${RDEPEND}
+       dev-util/intltool"