dev-libs/redland-bindings: Version bump, no keywords. Perl works. Bug 526158
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Fri, 25 Oct 2019 06:53:12 +0000 (08:53 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Fri, 25 Oct 2019 06:59:00 +0000 (08:59 +0200)
Bug: https://bugs.gentoo.org/526158
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
dev-libs/redland-bindings/Manifest
dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-bool.patch [new file with mode: 0644]
dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-php-config.patch [new file with mode: 0644]
dev-libs/redland-bindings/redland-bindings-1.0.17.1.ebuild [new file with mode: 0644]

index 08bdd972b8af8e58bcceee9b1219991e492256d9..5b18627b9a8f0f22a00d4d9f27aece49c1e6f7a0 100644 (file)
@@ -1 +1,2 @@
 DIST redland-bindings-1.0.14.1.tar.gz 792557 BLAKE2B fac20e9e2fbf9a4ea7299ef0b4a656ea3e5f1cbf436cd31c80e81be40dc95e074e557925b32ecf24091ce3cfe882d681318ae8402e14baf1e0966ec8a0a892ed SHA512 5e037a96f857c95bf4b9277d98c7de1fa41c4ba7e49e199eeb516458343587c796a10e857679c889406b22bca8617828a2bccd07c31b73f2366cdea39cefad15
+DIST redland-bindings-1.0.17.1.tar.gz 933290 BLAKE2B f58524c30958200af1fb3ec0f63b8aa9f3fd2120297321299cdd225ff9eb331f385c4418ed25987b955857e5046b5c6f0589210b807aae0dc6abe0b758d48cfc SHA512 c105d1232555d226d98efdc1e4edc1b6c953fdd004804e40926452b8f91d30159319a50af68fc3cfe242cf180d85383ef3ff925cc65ed5d0652096cc51f4d7c0
diff --git a/dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-bool.patch b/dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-bool.patch
new file mode 100644 (file)
index 0000000..3559451
--- /dev/null
@@ -0,0 +1,22 @@
+From: =?utf-8?q?Ond=C5=99ej_Sur=C3=BD?= <ondrej@sury.org>
+Date: Wed, 22 Jun 2016 10:28:48 +0200
+Subject: Don't undef bool, it's needed
+
+---
+ perl/CORE_wrap.c | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/perl/CORE_wrap.c b/perl/CORE_wrap.c
+index 46c2a46..4eb3785 100644
+--- a/perl/CORE_wrap.c
++++ b/perl/CORE_wrap.c
+@@ -1432,9 +1432,6 @@ SWIG_Perl_SetModule(swig_module_info *module) {
+ #ifdef eof
+   #undef eof
+ #endif
+-#ifdef bool
+-  #undef bool
+-#endif
+ #ifdef close
+   #undef close
+ #endif
diff --git a/dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-php-config.patch b/dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-php-config.patch
new file mode 100644 (file)
index 0000000..1ca8ded
--- /dev/null
@@ -0,0 +1,34 @@
+diff -aurN a/configure.ac b/configure.ac
+--- a/configure.ac     2014-05-10 18:38:09.000000000 -0400
++++ b/configure.ac     2016-10-12 14:27:04.635849601 -0400
+@@ -153,13 +153,17 @@
+   fi
+ fi
++AC_ARG_WITH([php-config],
++    AS_HELP_STRING([--with-php-config=path], [Custom path to php-config]))
++AS_IF([test "x$with_php_config" != "x"],
++  [AC_CHECK_PROG(PHP_CONFIG, php-config, ["$with_php_config/php-config"], [], [$with_php_config])],
++  [AC_CHECK_PROG(PHP_CONFIG, php-config, php-config)])
+-AC_CHECK_PROG(PHP_CONFIG, php-config, php-config)
+ if test "X$PHP_CONFIG" != X ; then
+-  PHP_VERSION=`$PHP_CONFIG --version`
+-  PHP_INCLUDES=`$PHP_CONFIG --includes`
+-  PHP_EXTENSION_DIR=`$PHP_CONFIG --extension-dir`
++  PHP_VERSION=`${PHP_CONFIG} --version`
++  PHP_INCLUDES=`${PHP_CONFIG} --includes`
++  PHP_EXTENSION_DIR=`${PHP_CONFIG} --extension-dir`
+   if test $PHP_VERSION '>' 5.0.0; then
+     PHP_SWIG="-php5"
+@@ -445,7 +449,7 @@
+   with_php=yes
+ fi
+-PHP_VERSION=`php-config --version 2>/dev/null`
++PHP_VERSION=`${PHP_CONFIG} --version 2>/dev/null`
+ if test "X$PHP_VERSION" != X; then
+   languages_available="$languages_available php($PHP_VERSION)"
+   if test $with_php = yes; then
diff --git a/dev-libs/redland-bindings/redland-bindings-1.0.17.1.ebuild b/dev-libs/redland-bindings/redland-bindings-1.0.17.1.ebuild
new file mode 100644 (file)
index 0000000..b03e953
--- /dev/null
@@ -0,0 +1,107 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+USE_PHP="php7-2"
+PHP_EXT_NAME="redland"
+PHP_EXT_OPTIONAL_USE="php"
+PHP_EXT_SKIP_PHPIZE="yes"
+
+inherit php-ext-source-r3 python-single-r1 autotools
+
+DESCRIPTION="Language bindings for Redland"
+HOMEPAGE="http://librdf.org/bindings/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux ~ppc-macos"
+IUSE="lua perl python php ruby"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/redland-1.0.14
+       lua? ( >=dev-lang/lua-5.1 )
+       perl? ( dev-lang/perl:= )
+       python? ( ${PYTHON_DEPS} )
+       ruby? ( dev-lang/ruby dev-ruby/log4r )
+"
+#      php? ( php_targets_php5-6? ( dev-lang/php:5.6[-threads] ) )
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       >=dev-lang/swig-2
+       sys-apps/sed"
+
+PATCHES=( "${FILESDIR}/${P}-bool.patch" )
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare(){
+       default
+       if use php ; then
+               local slot
+               for slot in $(php_get_slots); do
+                       php_init_slot_env "${slot}"
+                       eapply "${FILESDIR}/${P}-php-config.patch"
+                       eautoreconf
+               done
+       fi
+}
+
+src_configure() {
+       if use lua || use perl || use python || use ruby ; then
+               econf \
+                       $(use_with lua) \
+                       $(use_with perl) \
+                       $(use_with python) \
+                       --without-php \
+                       $(use_with ruby)
+       fi
+
+       if use php ; then
+               local slot
+               for slot in $(php_get_slots); do
+                       php_init_slot_env "${slot}"
+                       econf --with-php="${PHP_CURRENTSLOT}" \
+                               --with-php-config="${PHPPREFIX}/bin" \
+                               --without-lua --without-perl \
+                               --without-python --without-ruby
+               done
+       fi
+}
+
+src_compile() {
+       if use lua || use perl || use python || use ruby ; then
+               default
+       fi
+       use php && php-ext-source-r3_src_compile
+}
+
+src_install() {
+       if use lua || use perl || use python || use ruby ; then
+               emake DESTDIR="${D}" INSTALLDIRS=vendor luadir=/usr/$(get_libdir)/lua/5.1 install
+       fi
+
+       if use perl; then
+               find "${ED}" -type f -name perllocal.pod -delete
+               find "${ED}" -depth -mindepth 1 -type d -empty -delete
+       fi
+       use python && python_optimize
+
+       if use php ; then
+               local slot
+               for slot in $(php_get_slots); do
+                       php_init_slot_env "${slot}"
+                       exeinto "${EXT_DIR#$EPREFIX}"
+                       doexe "php/${PHP_EXT_NAME}.so"
+               done
+               php-ext-source-r3_createinifiles
+       fi
+       local DOCS=( AUTHORS ChangeLog NEWS README TODO )
+       local HTML_DOCS=( {NEWS,README,RELEASE,TODO}.html )
+       einstalldocs
+}