dev-python/pysvg: version bump, add python3 support
authorPoncho <poncho@spahan.ch>
Wed, 11 Dec 2019 07:48:50 +0000 (08:48 +0100)
committerAaron Bauman <bman@gentoo.org>
Thu, 12 Dec 2019 19:24:56 +0000 (14:24 -0500)
Closes: https://bugs.gentoo.org/702518
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Daniel Brandt <poncho@spahan.ch>
Closes: https://github.com/gentoo/gentoo/pull/13943
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-python/pysvg/Manifest
dev-python/pysvg/metadata.xml
dev-python/pysvg/pysvg-0.2.2_p3.ebuild [new file with mode: 0644]

index 9dabbf0950b43600d770cf3b207dd70f0dbf13e3..502f3a2bb2966a7e0ce1e1d398cab7f4b974e6f8 100644 (file)
@@ -1 +1,2 @@
 DIST pysvg-0.2.2.zip 623804 BLAKE2B c3fbbc6b62e80087059331f5af84b4da57a71aced8ee23764b5eb4d43e3c38dbba9b5df14294ff6b6c4af4f679dec5307295d1887fcfa64730d1979d1b4fcf48 SHA512 f0e39903f4290a0615ca7531ccc242b27086b639b2940b53ae185ff354843e56b184c1d1dbf63f0df4f9f9700c4224e878810354a0f0c77bcbb9efd1b4ac2f17
+DIST pysvg-py3-0.2.2.post3.tar.gz 23436 BLAKE2B a1f0ff710b73dd2e82811d322aa6365583febe8c9e7d690221690d285f94b3d0ae3f74e47b0e0ef236e389f0621ce5ad61ba00329a306c30a81cab0e77ee29db SHA512 3b0e30401ff9481df3fa5fde5b1e338bbabb86cdb846a11c08e8138563268311e20a4ce5317e5a31c337f2b8c5a3debb7abf8e0188e798e455378a363b31c95d
index a041c65e20548e34a50ac1096add39618348012d..82592044ff10eaa05cd2dcbee99c41888ce67380 100644 (file)
@@ -6,6 +6,6 @@
                <name>Python</name>
        </maintainer>
        <upstream>
-               <remote-id type="pypi">pysvg</remote-id>
+               <remote-id type="pypi">pysvg-py3</remote-id>
        </upstream>
 </pkgmetadata>
diff --git a/dev-python/pysvg/pysvg-0.2.2_p3.ebuild b/dev-python/pysvg/pysvg-0.2.2_p3.ebuild
new file mode 100644 (file)
index 0000000..31a5ef3
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="${PN}-py3"
+MY_PV="${PV/_p/.post}"
+
+DESCRIPTION="Python SVG document creation library"
+HOMEPAGE="https://github.com/alorence/pysvg-py3"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"