x11-misc/iconbox: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Tue, 24 Dec 2019 17:40:08 +0000 (18:40 +0100)
committerDavid Seifert <soap@gentoo.org>
Tue, 24 Dec 2019 17:40:08 +0000 (18:40 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
x11-misc/iconbox/iconbox-0.2.ebuild

index 7a1b08baee6511786ff901ddf51c7f44b3145e8a..5e38129b6e8dc77e999f54f24b02181148f4e713 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
 MY_P=${P/-/_}
 
@@ -12,16 +12,17 @@ SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc x86"
-IUSE=""
 
-RDEPEND="x11-libs/gtk+:2
-       dev-perl/Gtk2"
-DEPEND="${RDEPEND}"
+RDEPEND="
+       dev-lang/perl
+       dev-perl/Gtk2
+       x11-libs/gtk+:2"
 
 src_compile() { :; }
 
 src_install() {
        dobin iconbox{,conf}
-       dodoc Changelog README
+
+       einstalldocs
        doman *.1
 }