dev-python/cmd2: Disable test relying on 'vi'
authorMichał Górny <mgorny@gentoo.org>
Thu, 23 Apr 2020 11:53:17 +0000 (13:53 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 23 Apr 2020 12:12:44 +0000 (14:12 +0200)
Bug: https://bugs.gentoo.org/710174
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cmd2/cmd2-0.10.1.ebuild
dev-python/cmd2/cmd2-1.0.2.ebuild

index 4da2056c28bd478f59080364e944e1f11eed5f62..c6dd48a3be49880993464dc812d9d9728d127aeb 100644 (file)
@@ -28,6 +28,11 @@ BDEPEND="
 
 distutils_enable_tests pytest
 
+src_prepare() {
+       sed -i -e 's:test_which_editor_good:_&:' tests/test_cmd2.py || die
+       distutils-r1_src_prepare
+}
+
 src_test() {
        # tests rely on very specific text wrapping...
        local -x COLUMNS=80
index 20add50e79bbe5aa981961917aac685e19e0fb73..67caee784fa96a2d8d9d9970f308c1ed5204eb23 100644 (file)
@@ -28,6 +28,11 @@ BDEPEND="
 
 distutils_enable_tests pytest
 
+src_prepare() {
+       sed -i -e 's:test_which_editor_good:_&:' tests/test_cmd2.py || die
+       distutils-r1_src_prepare
+}
+
 src_test() {
        # tests rely on very specific text wrapping...
        local -x COLUMNS=80