dev-python/josepy: adding for certbot/acme
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 22 Dec 2017 22:52:36 +0000 (16:52 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 22 Dec 2017 22:52:36 +0000 (16:52 -0600)
Package-Manager: Portage-2.3.14, Repoman-2.3.6

dev-python/josepy/Manifest [new file with mode: 0644]
dev-python/josepy/josepy-1.0.1.ebuild [new file with mode: 0644]
dev-python/josepy/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/josepy/Manifest b/dev-python/josepy/Manifest
new file mode 100644 (file)
index 0000000..33e6de2
--- /dev/null
@@ -0,0 +1 @@
+DIST josepy-1.0.1.tar.gz 50251 BLAKE2B eb75e05dec890c92043357740829edf96f49f0c77b85211b9a9077ef39bfe59df2ee5952c1569559a07b6505870d796b3aa9e2b0fdba6943860b035f09a004b2 SHA512 51f0e1286a05ebc42f388d13e47e7bd2d1eb11ba1cf06f4d52d627d4a3c2d01f73f1ce9c9ff23ed7dd78ba18142af23e3de4277a63dc69b433bbc3e7aedfd6eb
diff --git a/dev-python/josepy/josepy-1.0.1.ebuild b/dev-python/josepy/josepy-1.0.1.ebuild
new file mode 100644 (file)
index 0000000..115d502
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="JOSE protocol implementation in Python"
+HOMEPAGE="https://github.com/jezdez/josepy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+       >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+       >=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+       >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/josepy/metadata.xml b/dev-python/josepy/metadata.xml
new file mode 100644 (file)
index 0000000..68065a2
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+       </maintainer>
+       <maintainer type="person">
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <longdescription lang="en">
+               JOSE protocol implementation in Python using cryptography
+               Originally developed as part of the ACME protocol implementation.
+       </longdescription>
+</pkgmetadata>