sys-libs/freeipmi: Bump to version 1.6.3
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 25 Jan 2019 13:03:32 +0000 (14:03 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 25 Jan 2019 13:03:32 +0000 (14:03 +0100)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-libs/freeipmi/Manifest
sys-libs/freeipmi/freeipmi-1.6.3.ebuild [new file with mode: 0644]

index 9d5a11391e659814b47187f66fc541482514b4f7..cc6723d1adedd21435581365149b387a1ecabf84 100644 (file)
@@ -2,3 +2,4 @@ DIST freeipmi-1.4.8.tar.gz 3185068 BLAKE2B 4133a7cdb5f66a28c07e965e6842c9d5931ed
 DIST freeipmi-1.5.7.tar.gz 3321187 BLAKE2B c6f7e9c4e0a03ce1d50972fee99741ec00a8f5beb0323d61d9217b3773eed33cb04e7bb92e1f293cb39c8012872babdc4774e6d81cf808615b8b283510e1e67c SHA512 a4d39d11d4e4b9635c272ee3a197729ac61c3e1c909c202498fb480c41289116eb933cd716fe2e0b5aa6dc258751ee204892bfb009398b6d5c2c65ee1cc58544
 DIST freeipmi-1.6.1.tar.gz 3398508 BLAKE2B 48c7cd791a635a1d82cc6304c8080aa2f88415c33a8dabf80a844305de5d21ef3bf20fd236c5a56d3a761fdadc1449b8750728465263828b157f93ba6080ad87 SHA512 f8ee5b3b59c0ccffeb52717a134cb8c149e42f3f66ea20420e4efbdbdc79d527e52e6d20b2a75a4406bc8c2190f368f83d8d36cef611eeeabd58ff7bf95380e5
 DIST freeipmi-1.6.2.tar.gz 3399236 BLAKE2B aedbfc785c1ec68418b9cfa79873d1b39a9591bfc5536a52c699c68558626c60aa11d29297252aa5fd2911fd47b88ab7010b8e72054431005f38a70268966bed SHA512 5c3f0b3f0632ad89a49a69aae28420c6ec342c9924aff5a8b6c0ccc1dc2f26f8c68906fbd1bc00f0f102dc50690596bb9e8c3443cdcbf93dabb91a7529d87ee8
+DIST freeipmi-1.6.3.tar.gz 3414736 BLAKE2B 8ae8d3744c98c5264c449da4cdd3335e36372dbef45d53e8329203bbb3bf39433f67393c2f0009a98e7c5e6afa52f461c8873c3e33334fe9189f5750a539b8c9 SHA512 473dc26fe22e5d801cb640d5e99ded715e22e8c65d21632145e6711a24ffd60e09a842194d4cc87ad3f506f4b5456be393d87baf726d2479a34f6fc8644eedd7
diff --git a/sys-libs/freeipmi/freeipmi-1.6.3.ebuild b/sys-libs/freeipmi/freeipmi-1.6.3.ebuild
new file mode 100644 (file)
index 0000000..d157626
--- /dev/null
@@ -0,0 +1,91 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+AT_M4DIR="config"
+
+DESCRIPTION="Provides Remote-Console and System Management Software as per IPMI v1.5/2.0"
+HOMEPAGE="https://www.gnu.org/software/freeipmi/"
+
+MY_P="${P/_/.}"
+S="${WORKDIR}"/${MY_P}
+[[ ${MY_P} == *.beta* ]] && ALPHA="-alpha"
+SRC_URI="mirror://gnu${ALPHA}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug nagios"
+
+RDEPEND="dev-libs/libgcrypt:0="
+DEPEND="${RDEPEND}
+       virtual/os-headers"
+RDEPEND="${RDEPEND}
+       nagios? (
+               || ( net-analyzer/icinga net-analyzer/nagios )
+               dev-lang/perl
+       )
+"
+
+src_configure() {
+       local myeconfargs=(
+               $(use_enable debug)
+               --disable-static
+               --disable-init-scripts
+               --localstatedir="${EPREFIX}"/var
+       )
+
+       econf "${myeconfargs[@]}"
+}
+
+# There are no tests
+src_test() { :; }
+
+src_install() {
+       default
+
+       # freeipmi by defaults install _all_ commands to /usr/sbin, but
+       # quite a few can be run remotely as standard user, so move them
+       # in /usr/bin afterwards.
+       dodir /usr/bin
+       for file in ipmi{detect,ping,power,console}; do
+               mv "${ED}"/usr/{s,}bin/${file} || die
+
+               # The default install symlinks these commands to add a dash
+               # after the ipmi prefix; we repeat those after move for
+               # consistency.
+               rm "${ED}"/usr/sbin/${file/ipmi/ipmi-}
+               dosym ${file} /usr/bin/${file/ipmi/ipmi-}
+       done
+
+       # Install the nagios plugin in its proper place, if desired
+       if use nagios; then
+               dodir /usr/$(get_libdir)/nagios/plugins
+               mv "${ED}"/usr/share/doc/${PF}/contrib/nagios/nagios_ipmi_sensors.pl \
+                       "${ED}"/usr/$(get_libdir)/nagios/plugins/ || die
+               fperms 0755 /usr/$(get_libdir)/nagios/plugins/nagios_ipmi_sensors.pl
+
+               insinto /etc/icinga/conf.d
+               newins "${FILESDIR}"/freeipmi.icinga freeipmi-command.cfg
+       fi
+
+       dodoc AUTHORS ChangeLog* DISCLAIMER* NEWS README* TODO doc/*.txt
+
+       keepdir \
+               /var/cache/ipmimonitoringsdrcache \
+               /var/lib/freeipmi \
+               /var/log/ipmiconsole
+
+       # starting from version 1.2.0 the two daemons are similar enough
+       newinitd "${FILESDIR}"/bmc-watchdog.initd.4 ipmidetectd
+       newconfd "${FILESDIR}"/ipmidetectd.confd ipmidetectd
+
+       newinitd "${FILESDIR}"/bmc-watchdog.initd.4 bmc-watchdog
+       newconfd "${FILESDIR}"/bmc-watchdog.confd bmc-watchdog
+
+       newinitd "${FILESDIR}"/bmc-watchdog.initd.4 ipmiseld
+       newconfd "${FILESDIR}"/ipmiseld.confd ipmiseld
+
+       find "${ED}" -name "*.la" -delete || die
+}