app-leechcraft/lc-musiczombie: EAPI bump, subslot deps
author0xd34df00d <0xd34df00d@gmail.com>
Fri, 17 Apr 2020 18:24:05 +0000 (20:24 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 6 May 2020 11:50:51 +0000 (14:50 +0300)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild

index 362f8279c93310fd106853e65c339d954615ae9c..9a98bff590d8340fb9755f236f33111bf21c4bc2 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit leechcraft
 
@@ -9,20 +9,18 @@ DESCRIPTION="MusicBrainz client plugin for LeechCraft"
 
 SLOT="0"
 KEYWORDS=""
-IUSE="debug acoustid"
+IUSE="acoustid debug"
 
 DEPEND="~app-leechcraft/lc-core-${PV}
-       dev-qt/qtnetwork:5
-       dev-qt/qtwidgets:5
        dev-qt/qtconcurrent:5
        dev-qt/qtnetwork:5
        dev-qt/qtxml:5
-       acoustid? ( media-libs/chromaprint )"
+       acoustid? ( media-libs/chromaprint:= )"
 RDEPEND="${DEPEND}"
 
 src_configure() {
        local mycmakeargs=(
                -DWITH_MUSICZOMBIE_CHROMAPRINT=$(usex acoustid)
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }