dev-tex/pythontex: installation fixed
authorAndrey Grozin <grozin@gentoo.org>
Sat, 22 Feb 2020 08:19:29 +0000 (15:19 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sat, 22 Feb 2020 08:19:29 +0000 (15:19 +0700)
Closes: https://bugs.gentoo.org/show_bug.cgi?id=709882
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-tex/pythontex/pythontex-0.17.ebuild

index 267d1e510960b080a1ce3f17072f0f84900124cc..31f770632569207f64ecda95dacb32b73d966de2 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/gpoore/pythontex/archive/v${PV}.tar.gz -> ${P}.tar.g
 SLOT="0"
 LICENSE="LPPL-1.3 BSD"
 KEYWORDS="~amd64 ~x86"
-IUSE="highlighting"
+IUSE="doc highlighting"
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
@@ -33,7 +33,8 @@ src_compile() {
 }
 
 src_install() {
-       dodoc ${PN}/README "${S}"/*rst ${PN}_quickstart/*
+       dodoc *rst
+       use doc && dodoc ${PN}_quickstart/*pdf ${PN}/*pdf
 
        cd ${PN} || die
 
@@ -45,5 +46,5 @@ src_install() {
        }
        python_foreach_impl installation
 
-       latex-package_src_doinstall dtx ins sty
+       latex-package_src_doinstall sty
 }