Version bump.
authorTim Harder <radhermit@gentoo.org>
Wed, 11 Jan 2012 23:15:55 +0000 (23:15 +0000)
committerTim Harder <radhermit@gentoo.org>
Wed, 11 Jan 2012 23:15:55 +0000 (23:15 +0000)
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64

media-gfx/apngasm/ChangeLog
media-gfx/apngasm/apngasm-2.5.ebuild [new file with mode: 0644]
media-gfx/apngopt/ChangeLog
media-gfx/apngopt/apngopt-1.1.ebuild [new file with mode: 0644]
media-gfx/pngcrush/ChangeLog
media-gfx/pngcrush/pngcrush-1.7.23.ebuild [new file with mode: 0644]

index a563fff663bf35c5eda988708e063c6129f42bad..eb424a53c38bb0569753af9b3a4c25a61e9f0bda 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for media-gfx/apngasm
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/ChangeLog,v 1.3 2011/09/21 04:26:24 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/ChangeLog,v 1.4 2012/01/11 23:13:07 radhermit Exp $
+
+*apngasm-2.5 (11 Jan 2012)
+
+  11 Jan 2012; Tim Harder <radhermit@gentoo.org> +apngasm-2.5.ebuild:
+  Version bump.
 
 *apngasm-2.4 (21 Sep 2011)
 
diff --git a/media-gfx/apngasm/apngasm-2.5.ebuild b/media-gfx/apngasm/apngasm-2.5.ebuild
new file mode 100644 (file)
index 0000000..cca3a35
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/apngasm-2.5.ebuild,v 1.1 2012/01/11 23:13:07 radhermit Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="create an APNG from multiple PNG files"
+HOMEPAGE="http://sourceforge.net/projects/apngasm/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng[apng]
+       sys-libs/zlib"
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig
+       app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+       emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) --libs libpng --libs zlib)" ${PN}
+}
+
+src_install() {
+       dobin ${PN}
+       dodoc readme.txt
+}
index 27118c1d2df1fe8db98912b06d9599b3e04fd20e..b470c82056d12b1afe6fc329e08c179da617d5ff 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for media-gfx/apngopt
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngopt/ChangeLog,v 1.3 2011/06/29 20:01:56 vapier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngopt/ChangeLog,v 1.4 2012/01/11 23:10:53 radhermit Exp $
+
+*apngopt-1.1 (11 Jan 2012)
+
+  11 Jan 2012; Tim Harder <radhermit@gentoo.org> +apngopt-1.1.ebuild:
+  Version bump.
 
   29 Jun 2011; Mike Frysinger <vapier@gentoo.org> apngopt-1.0.ebuild:
   Tweak DESCRIPTION #373167 by Denilson Sá.
diff --git a/media-gfx/apngopt/apngopt-1.1.ebuild b/media-gfx/apngopt/apngopt-1.1.ebuild
new file mode 100644 (file)
index 0000000..b963f38
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngopt/apngopt-1.1.ebuild,v 1.1 2012/01/11 23:10:53 radhermit Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="optimize APNG images"
+HOMEPAGE="http://sourceforge.net/projects/apng/"
+SRC_URI="mirror://sourceforge/apng/APNG_Optimizer/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig
+       app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+       emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) --libs zlib)" ${PN}
+}
+
+src_install() {
+       dobin ${PN}
+       dodoc readme.txt
+}
index 8b3e772cab6e1820f06fcc86d212c87bd1aeca2f..a2bc355e49012c21b9ce8d9d3f10acbcc27827c8 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for media-gfx/pngcrush
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngcrush/ChangeLog,v 1.76 2011/12/08 09:16:32 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngcrush/ChangeLog,v 1.77 2012/01/11 23:15:55 radhermit Exp $
+
+*pngcrush-1.7.23 (11 Jan 2012)
+
+  11 Jan 2012; Tim Harder <radhermit@gentoo.org> +pngcrush-1.7.23.ebuild:
+  Version bump.
 
 *pngcrush-1.7.22 (08 Dec 2011)
 
diff --git a/media-gfx/pngcrush/pngcrush-1.7.23.ebuild b/media-gfx/pngcrush/pngcrush-1.7.23.ebuild
new file mode 100644 (file)
index 0000000..4cb1ea9
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngcrush/pngcrush-1.7.23.ebuild,v 1.1 2012/01/11 23:15:55 radhermit Exp $
+
+EAPI=4
+
+MY_P=${P}-nolib
+
+inherit toolchain-funcs
+
+DESCRIPTION="Portable Network Graphics (PNG) optimizing utility"
+HOMEPAGE="http://pmt.sourceforge.net/pngcrush/"
+SRC_URI="mirror://sourceforge/pmt/${MY_P}.tar.xz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=media-libs/libpng-1.4:0
+       sys-libs/zlib"
+DEPEND="${RDEPEND}
+       app-arch/xz-utils"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+       emake \
+               CC="$(tc-getCC)" \
+               LD="$(tc-getCC)" \
+               CFLAGS="${CFLAGS} -Wall" \
+               LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+       dobin ${PN}
+       dohtml ChangeLog.html
+}