dev-python/jira: Remove Py2
authorDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:13:05 +0000 (17:13 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:13:05 +0000 (17:13 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/jira/jira-1.0.14-r2.ebuild

index 69e2892abc7553a5bb2c1adc24dd8b25b8dcff89..2c463d37e409effa6aea8a6e874e2054b144437c 100644 (file)
@@ -2,7 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+PYTHON_COMPAT=( python3_{5,6} )
 inherit distutils-r1
 
 DESCRIPTION="Python library for interacting with the JIRA REST API"
@@ -13,8 +14,6 @@ LICENSE="BSD-2"
 SLOT="0"
 KEYWORDS="~amd64"
 IUSE="magic jirashell kerberos oauth"
-REQUIRED_USE="kerberos? ( !python_targets_python2_7 )
-       jirashell? ( || ( $(python_gen_useflags -3) ) )"
 
 DEPEND="
        >=dev-python/pbr-3.0[${PYTHON_USEDEP}]
@@ -28,14 +27,15 @@ RDEPEND="
        dev-python/six[${PYTHON_USEDEP}]
        magic? ( dev-python/filemagic[${PYTHON_USEDEP}] )
        jirashell? (
-               $(python_gen_cond_dep '
-                       dev-python/ipython[${PYTHON_USEDEP}]
-                       dev-python/requests-oauthlib[${PYTHON_USEDEP}]
-               ' -3)
+               dev-python/ipython[${PYTHON_USEDEP}]
+               dev-python/requests-oauthlib[${PYTHON_USEDEP}]
        )
-       kerberos? ( $(python_gen_cond_dep 'dev-python/requests-kerberos[${PYTHON_USEDEP}]' -3) )
+       kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
        oauth? (
-               || ( dev-python/pycryptodome[${PYTHON_USEDEP}] dev-python/pycrypto[${PYTHON_USEDEP}] )
+               || (
+                       dev-python/pycryptodome[${PYTHON_USEDEP}]
+                       dev-python/pycrypto[${PYTHON_USEDEP}]
+               )
                dev-python/requests-oauthlib[${PYTHON_USEDEP}]
        )
        "