x11-plugins/wmcms: EAPI bump, fix compilation with new libdockapp
authorBernard Cafarelli <voyageur@gentoo.org>
Fri, 21 Aug 2015 21:26:53 +0000 (23:26 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Sun, 23 Aug 2015 19:14:39 +0000 (21:14 +0200)
Fixes bug #558362 by Toralf Förster <toralf.foerster@gmx.de>

Package-Manager: portage-2.2.20.1

x11-plugins/wmcms/Manifest
x11-plugins/wmcms/wmcms-0.3.5-r1.ebuild
x11-plugins/wmcms/wmcms-0.3.5-r2.ebuild [new file with mode: 0644]

index 2d52b490a2e8c95e64d74c96f43662c599cf7e39..d70557eb8ec2b9581f171137b8b0bef049c28c01 100644 (file)
@@ -1 +1 @@
-DIST wmcms-0.3.5.tar.bz2 18920 SHA256 9b47672b3fa5a2474fe26dabb0e95030a4792766ce6577391ab1cd784f21d09b
+DIST wmcms-0.3.5.tar.bz2 18920 SHA256 9b47672b3fa5a2474fe26dabb0e95030a4792766ce6577391ab1cd784f21d09b SHA512 f2852f8b81e1eac0396ca0964590fdf2560b97b5ee5266288641487ddfe77879e552c5e77e42f398ecf974a9030dd147ad64eedf7f7c32af53d69be31c8598fd WHIRLPOOL 5271e3a7c42745ea8f0b2a27dcba8d717e9b3e9243a862975d1f6b6f8430a0a92a80d3eaa0695ad8ba620a4b9d32c5a692c6178780ebde1168ff30bc5b478a84
index 7846476faadb2aac27ffcd9d1d9f7285a9851a6f..42e7f824372f0f4394d16e34ad8274b01b39122e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -13,7 +13,8 @@ SLOT="0"
 KEYWORDS="amd64 ppc ppc64 sparc x86"
 IUSE=""
 
-DEPEND="x11-libs/libdockapp"
+RDEPEND="<x11-libs/libdockapp-0.7"
+DEPEND="${RDEPEND}"
 
 src_unpack() {
        unpack ${A}
diff --git a/x11-plugins/wmcms/wmcms-0.3.5-r2.ebuild b/x11-plugins/wmcms/wmcms-0.3.5-r2.ebuild
new file mode 100644 (file)
index 0000000..cbb2f6d
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="WindowMaker CPU and Memory Usage Monitor Dock App"
+SRC_URI="http://orbita.starmedia.com/~neofpo/files/${P}.tar.bz2"
+HOMEPAGE="http://orbita.starmedia.com/~neofpo/wmcms.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libdockapp-0.7:="
+
+src_prepare() {
+       epatch "${FILESDIR}"/wmcms-0.3.5-s4t4n.patch
+
+       # Respect LDFLAGS, see bug #335031
+       sed -e 's/ -o wmcms/ ${LDFLAGS} -o wmcms/' -i Makefile || die
+
+       sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i *.c || die
+}
+
+src_compile() {
+       emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+       dobin wmcms
+}