dev-python/pycxx: Fixes use of banned EXAMPLES
authorSebastian Pipping <sping@gentoo.org>
Mon, 2 Mar 2020 22:22:27 +0000 (23:22 +0100)
committerSebastian Pipping <sping@gentoo.org>
Mon, 2 Mar 2020 22:22:27 +0000 (23:22 +0100)
Closes: https://bugs.gentoo.org/711314
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.84, Repoman-2.3.20

dev-python/pycxx/pycxx-7.1.2-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pycxx/pycxx-7.1.2-r1.ebuild b/dev-python/pycxx/pycxx-7.1.2-r1.ebuild
new file mode 100644 (file)
index 0000000..7ebe1b3
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+python_prepare_all() {
+       # Without this, pysvn fails.
+       # Src/Python3/cxxextensions.c: No such file or directory
+       sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
+
+       distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( Doc/. )
+       if use examples ; then
+               insinto /usr/share/doc/${PF}/examples
+               doins -r Demo/Python{2,3}/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+       distutils-r1_python_install_all
+}