net-vpn/wireguard-modules: allow out of tree kernel builds
authorJason A. Donenfeld <zx2c4@gentoo.org>
Fri, 27 Dec 2019 15:20:54 +0000 (16:20 +0100)
committerJason A. Donenfeld <zx2c4@gentoo.org>
Fri, 27 Dec 2019 15:25:10 +0000 (16:25 +0100)
We also update the version situation description.

Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
net-vpn/wireguard-modules/wireguard-modules-0.0.20191226.ebuild
net-vpn/wireguard-modules/wireguard-modules-9999.ebuild

index 2fe86edba28eaee27835166d77dbc5472a19a035..dd0ff73d49584d629e7b8a7e3b195b9d5dee6142 100644 (file)
@@ -33,14 +33,21 @@ CONFIG_CHECK="NET INET NET_UDP_TUNNEL CRYPTO_ALGAPI"
 pkg_setup() {
        if use module; then
                linux-mod_pkg_setup
-               if kernel_is -lt 3 10 0 || kernel_is -ge 5 6 0; then
-                       die "This version of ${PN} requires 3.10 <= Linux <= 5.5.y"
+               if kernel_is -ge 5 6 0; then
+                       eerror
+                       eerror "WireGuard has been merged upstream in Linux 5.6. Therefore,"
+                       eerror "you no longer need this compatibility ebuild. Instead, simply"
+                       eerror "enable CONFIG_WIREGUARD=y in your kernel configuration."
+                       eerror
+                       die "Use CONFIG_WIREGUARD=y for kernels >= 5.6, and do not use this package."
+               elif kernel_is -lt 3 10 0; then
+                       die "This version of ${PN} requires Linux >= 3.10."
                fi
        fi
 }
 
 src_compile() {
-       BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+       BUILD_PARAMS="KERNELDIR=${KV_OUT_DIR}"
        use debug && BUILD_PARAMS="CONFIG_WIREGUARD_DEBUG=y ${BUILD_PARAMS}"
        use module && linux-mod_src_compile
 }
index 2fe86edba28eaee27835166d77dbc5472a19a035..dd0ff73d49584d629e7b8a7e3b195b9d5dee6142 100644 (file)
@@ -33,14 +33,21 @@ CONFIG_CHECK="NET INET NET_UDP_TUNNEL CRYPTO_ALGAPI"
 pkg_setup() {
        if use module; then
                linux-mod_pkg_setup
-               if kernel_is -lt 3 10 0 || kernel_is -ge 5 6 0; then
-                       die "This version of ${PN} requires 3.10 <= Linux <= 5.5.y"
+               if kernel_is -ge 5 6 0; then
+                       eerror
+                       eerror "WireGuard has been merged upstream in Linux 5.6. Therefore,"
+                       eerror "you no longer need this compatibility ebuild. Instead, simply"
+                       eerror "enable CONFIG_WIREGUARD=y in your kernel configuration."
+                       eerror
+                       die "Use CONFIG_WIREGUARD=y for kernels >= 5.6, and do not use this package."
+               elif kernel_is -lt 3 10 0; then
+                       die "This version of ${PN} requires Linux >= 3.10."
                fi
        fi
 }
 
 src_compile() {
-       BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+       BUILD_PARAMS="KERNELDIR=${KV_OUT_DIR}"
        use debug && BUILD_PARAMS="CONFIG_WIREGUARD_DEBUG=y ${BUILD_PARAMS}"
        use module && linux-mod_src_compile
 }