dev-qt/qtlocation: Fix src_configure for out-of-source build
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 10 Apr 2020 08:37:14 +0000 (10:37 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 10 Apr 2020 08:37:56 +0000 (10:37 +0200)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-qt/qtlocation/qtlocation-5.14.2.ebuild

index 838cb1e243aca77db155a9b69d17b34375a8b8e7..07669c361d6498bfc6e8c2158c389f71c11cac0a 100644 (file)
@@ -40,7 +40,8 @@ QT5_TARGET_SUBDIRS=(
 src_configure() {
        # src/plugins/geoservices requires files that are only generated when
        # qmake is run in the root directory. Bug 633776.
-       mkdir -p "${QT5_BUILD_DIR}" || die
-       qt5_qmake "${QT_BUILD_DIR}"
+       mkdir -p "${QT5_BUILD_DIR}"/src/location || die
+       qt5_qmake "${QT5_BUILD_DIR}"
+       cp src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
        qt5-build_src_configure
 }