sci-geosciences/xtide: version bump to 2.13.2
authorJulian Ospald <hasufell@gentoo.org>
Mon, 17 Aug 2015 20:17:06 +0000 (22:17 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Mon, 17 Aug 2015 20:17:31 +0000 (22:17 +0200)
sci-geosciences/xtide/Manifest
sci-geosciences/xtide/files/xtide-2.13.2-clang.patch [new file with mode: 0644]
sci-geosciences/xtide/xtide-2.13.2.ebuild [new file with mode: 0644]

index 00e93bb9a915717c2e7d47786dd66ffaf6bed16f..80e82059c5f63eb2d976bc6dff758be9bf482546 100644 (file)
@@ -1,2 +1,3 @@
 DIST xtide-2.13.1.tar.bz2 476238 SHA256 f537377223ebc073998bbf2c7c475e57374ee60a638e29d029f84ba01fb6f365 SHA512 90ad5f50c0f234a8993e8fca99865587617996ac422941c3450826a998556b0429ff1c16a9f8ab7a1b4255b938a7e928258fd090094ad3c8556f94a64eb8e54d WHIRLPOOL aed1390712895b866d96923c46281517ee7157e2460defb9049ec484c51e9828af8306b5a42e10d130de83186e4d36b7d9fac0c3e74635958e2245e6c52f6ece
+DIST xtide-2.13.2.tar.bz2 481183 SHA256 fabf6b3097bb345598649ea55d1f2db269cbb651cddd73c60a9768088173d542 SHA512 31b35190932413bf5021c82c640ec3f03424807ffd5295abd8ab9554febbe495896bc0d08f901e70e11b04d92c0d1991b8214dcdd5e95e04173f3e7bbf5faec0 WHIRLPOOL 7c7858918288fa19a8742c7b5876c83f1dea1c2e85c250084061b1e1aead9929bf3b0c8162b6cd26ac4bcbf548e14ab6774edb2bc4762b809374c18e4cd550c3
 DIST xtide-2.13.tar.bz2 465679 SHA256 a73c530c83a9346bf85fe9545551eef3fbedfb24adf18f63c9e7dba0388e0d0a SHA512 2324d3f5150a46ea1fd6c2af3379c8ea4f147034f153ac4b0393ef3aaa2178bfdafc01499f27db643b5ec78b4825c99b20957f5e47f6174fe1612480dc79dcd1 WHIRLPOOL af9fe8377fec84a449e06cfac542b2d792ebe1df904e036775b3e5b659e874d5193e0416b061dddcffc2419610d48864207bba27d557fe05fdcd7560c20afb53
diff --git a/sci-geosciences/xtide/files/xtide-2.13.2-clang.patch b/sci-geosciences/xtide/files/xtide-2.13.2-clang.patch
new file mode 100644 (file)
index 0000000..090aa6c
--- /dev/null
@@ -0,0 +1,33 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Mon Aug 17 20:15:03 UTC 2015
+Subject: fix build with clang
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -22,26 +22,6 @@
+ AC_SUBST([ADDED_CPPFLAGS])
+ AC_SUBST([ADDED_CXXFLAGS])
+-# Extended initializer lists were added in 4.4.
+-AC_MSG_CHECKING([if using a version of GCC older than 4.4])
+-AC_PREPROC_IFELSE(
+-  [AC_LANG_SOURCE([[
+-#ifdef __GNUC__
+-#if (__GNUC__ * 100 + __GNUC_MINOR__) < 404
+-#FAIL
+-#endif
+-#endif
+-  ]])],
+-  [
+-    AC_MSG_RESULT(no)
+-  ],
+-  [
+-    AC_MSG_RESULT(yes)
+-    AC_MSG_NOTICE([if using GCC, version 4.4 or later is required])
+-    AC_MSG_ERROR([GCC too old])
+-  ]
+-)
+-
+ # /tmp/ccB6kF2d.s: Assembler messages:
+ # /tmp/ccB6kF2d.s:1325: Error: symbol `_ZZN10SafeVectorIdEixEPdS1_jE19__PRETTY_FUNCTION__' is already defined
+ # /tmp/ccB6kF2d.s:1330: Error: symbol `_ZZN10SafeVectorI5AngleEixEPS0_S2_jE19__PRETTY_FUNCTION__' is already defined
diff --git a/sci-geosciences/xtide/xtide-2.13.2.ebuild b/sci-geosciences/xtide/xtide-2.13.2.ebuild
new file mode 100644 (file)
index 0000000..56b0fc1
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="XTide provides tide and current predictions in a wide variety of formats"
+HOMEPAGE="http://www.flaterco.com/xtide/"
+SRC_URI="ftp://ftp.flaterco.com/xtide/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gps"
+
+DEPEND="
+       media-libs/libpng:0
+       >=sci-geosciences/libtcd-2.2.5_p2
+       x11-libs/libX11
+       x11-libs/libXaw3d
+       x11-libs/libXpm
+       x11-libs/libXt
+       gps? ( sci-geosciences/gpsd )"
+RDEPEND="${DEPEND}
+       media-fonts/font-schumacher-misc"
+DEPEND="${DEPEND}"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-2.13.1-{Werror,gps-switch}.patch \
+               "${FILESDIR}"/${P}-clang.patch
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_with gps)
+}
+
+src_install() {
+       dobin xtide tide xttpd
+       doman *.[18]
+
+       echo 'HFILE_PATH=/usr/share/harmonics' > 50xtide_harm
+       doenvd 50xtide_harm
+
+       newicon -s 48 iconsrc/icon_48x48_orig.png ${PN}.png
+
+       make_desktop_entry ${PN} 'Tide prediction' ${PN} 'Science'
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}