dev-python/pygal: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:38:51 +0000 (13:38 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:38:51 +0000 (13:38 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pygal/pygal-2.4.0.ebuild [deleted file]

diff --git a/dev-python/pygal/pygal-2.4.0.ebuild b/dev-python/pygal/pygal-2.4.0.ebuild
deleted file mode 100644 (file)
index b50eb48..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="A python SVG charts generator"
-HOMEPAGE="https://github.com/Kozea/pygal/"
-# PyPI tarballs do not contain docs
-# https://github.com/Kozea/pygal/pull/428
-SRC_URI="https://github.com/Kozea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/lxml[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       media-gfx/cairosvg[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               ${RDEPEND}
-               dev-python/pyquery[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )
-"
-
-# CHANGELOG is a symlink to docs/changelog.rst
-DOCS=( docs/changelog.rst README.md )
-
-python_prepare_all() {
-       sed -i "/sphinx.ext.intersphinx/d" docs/conf.py || die
-       # Not actually required unless we want to do setup.py test
-       # https://github.com/Kozea/pygal/issues/430
-       sed -i "s/'pytest-runner'\(,\)\?//" setup.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build docs docs/_build/html || die
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       py.test || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       if use examples; then
-               docinto examples
-               dodoc -r demo/.
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-       distutils-r1_python_install_all
-}