dev-libs/double-conversion: Do not use hardcoded g++ but tc-getCXX to fix cross compi...
authorAlexis Ballier <aballier@gentoo.org>
Sat, 17 Jun 2017 12:00:10 +0000 (14:00 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 17 Jun 2017 14:41:20 +0000 (16:41 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-libs/double-conversion/double-conversion-2.0.1.ebuild

index c7e58c05e29db128054a656a29224a1fade6d17b..107df7ef7cf74f55e891fc1565ad7ceb63f35119 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=5
 
-inherit scons-utils eutils
+inherit scons-utils eutils toolchain-funcs
 
 DESCRIPTION="Binary-decimal and decimal-binary conversion routines for IEEE doubles"
 HOMEPAGE="https://github.com/google/double-conversion"
@@ -21,6 +21,7 @@ src_prepare() {
 }
 
 src_compile() {
+       sed -i -e "s/g++/$(tc-getCXX)/" SConstruct || die
        escons ${LIBNAME}.so.1
        use static-libs && escons ${LIBNAME}.a
 }