dev-libs/wayland-9999: Port to EAPI-6
authorMart Raudsepp <leio@gentoo.org>
Sun, 9 Apr 2017 23:27:41 +0000 (02:27 +0300)
committerMart Raudsepp <leio@gentoo.org>
Mon, 10 Apr 2017 01:01:15 +0000 (04:01 +0300)
Also try to address socket path 108 byte limit restriction caused test
failures by cutting down the XDG_RUNTIME_DIR subdir length.
Wayland tests used to create a wayland-tests/ subdir under it, but since
before 1.13.0 it creates a wayland-tests-RANDOM/ subdir (RANDOM is 6
random characters), which makes tests fail on socket path length even with
PORTAGE_TMPDIR=/tmp, let alone /var/tmp.
I think shortening the subdir from "runtime-dir" to "xdr" makes it fit
in both cases, unless we are dealing with a 1.xx.y-r1 revision, in which
case /var/tmp might fail.

dev-libs/wayland/wayland-9999.ebuild

index cb4da40703c5180661d1e384272864115694bfcb..2863cc6657ee88867f77e169482ffb3104646127 100644 (file)
@@ -1,23 +1,21 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
 
 if [[ ${PV} = 9999* ]]; then
-       EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
        GIT_ECLASS="git-r3"
-       EXPERIMENTAL="true"
-       AUTOTOOLS_AUTORECONF=1
 fi
 
-inherit autotools-multilib toolchain-funcs $GIT_ECLASS
+inherit autotools libtool ltprune multilib-minimal toolchain-funcs $GIT_ECLASS
 
 DESCRIPTION="Wayland protocol libraries"
 HOMEPAGE="https://wayland.freedesktop.org/"
 
 if [[ $PV = 9999* ]]; then
-       SRC_URI="${SRC_PATCHES}"
-       KEYWORDS=""
+       SRC_URI=""
 else
        SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
        KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -39,22 +37,36 @@ DEPEND="${RDEPEND}
        )
        virtual/pkgconfig"
 
+src_prepare() {
+       default
+       [[ $PV = 9999* ]] && eautoreconf || elibtoolize
+}
+
 multilib_src_configure() {
-       local myeconfargs=(
-               $(multilib_native_use_enable doc documentation)
-               $(multilib_native_enable dtd-validation)
-       )
+       local myconf
        if tc-is-cross-compiler ; then
-               myeconfargs+=( --with-host-scanner )
+               myconf+=' --with-host-scanner '
        fi
 
-       autotools-utils_src_configure
+       ECONF_SOURCE="${S}" econf \
+               --disable-static \
+               $(multilib_native_use_enable doc documentation) \
+               $(multilib_native_enable dtd-validation) \
+               ${myconf}
+}
+
+multilib_src_install_all() {
+       prune_libtool_files
+       einstalldocs
 }
 
 src_test() {
-       export XDG_RUNTIME_DIR="${T}/runtime-dir"
+       # We set it on purpose to only a short subdir name, as socket paths are
+       # created in there, which are 108 byte limited. With this it hopefully
+       # barely fits to the limit with /var/tmp/portage/$CAT/$PF/temp/xdr
+       export XDG_RUNTIME_DIR="${T}"/xdr
        mkdir "${XDG_RUNTIME_DIR}" || die
        chmod 0700 "${XDG_RUNTIME_DIR}" || die
 
-       autotools-multilib_src_test
+       multilib-minimal_src_test
 }