dev-ros/python_qt_binding: bump to 0.3.3
authorAlexis Ballier <aballier@gentoo.org>
Fri, 10 Nov 2017 08:15:53 +0000 (09:15 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 10 Nov 2017 08:51:17 +0000 (09:51 +0100)
Package-Manager: Portage-2.3.13, Repoman-2.3.4

dev-ros/python_qt_binding/Manifest
dev-ros/python_qt_binding/python_qt_binding-0.3.3.ebuild [new file with mode: 0644]

index a77dabb48ab0ff698896f5418c6c533c31c3aaba..ea949d6666993b51114a85142140aa2d600e72e9 100644 (file)
@@ -1 +1,2 @@
 DIST python_qt_binding-0.3.2.tar.gz 12047 SHA256 1ef3a85cc304028711f35de983c78fdc1f78d476e1239519bd8883cbe99aba16 SHA512 777d7ba00652d34994648615125f6c426170a1723570de35b9e5a060d0f077b563a57c9b0cbe7bd85a7ed2f5f011797e9102918a27df4f0096831cce0bb80304 WHIRLPOOL 3490e9229d675a8a753363a91fc785ab255385b358c7829824d50abae389b214aa88f49970d60a7bbda255c430fd8202b63c7586f2342808c85b8fe55bc8edae
+DIST python_qt_binding-0.3.3.tar.gz 12114 SHA256 3c83d03aa1663052daa7819fd20e15f4061cd4e37a82a71b27798f801252f8d6 SHA512 0dfd698b390a87e0619e93a291656c329ff37713411c5a805e720aeedf9fefd43fc780bbdba351cd1a73e30d67ce8e93a98b5ba6b5584a807d829611ac232263 WHIRLPOOL b6a075d0c69a0856e88d74b79e9e2d20de34a2cd18dd0573a5b069c2b434a1fe1b3f47dd16a1647c58c4efd4df9bef62033a323d63836b58dd1df8b27500417f
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.3.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.3.ebuild
new file mode 100644 (file)
index 0000000..9e4951a
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"