media-plugins/vdr-live: QA, fixed DuplicateFiles
authorJoerg Bornkessel <hd_brummy@gentoo.org>
Thu, 19 Dec 2019 22:56:30 +0000 (23:56 +0100)
committerJoerg Bornkessel <hd_brummy@gentoo.org>
Thu, 19 Dec 2019 22:57:20 +0000 (23:57 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
media-plugins/vdr-live/files/confd-0.3 [deleted file]
media-plugins/vdr-live/files/rc-addon-0.3.sh [deleted file]
media-plugins/vdr-live/files/vdr-live-0.3.0_p20130504-c++11.patch [deleted file]
media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild [deleted file]

diff --git a/media-plugins/vdr-live/files/confd-0.3 b/media-plugins/vdr-live/files/confd-0.3
deleted file mode 100644 (file)
index cb1dce0..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# configuration of media-plugins/vdr-live
-
-# for people who want more secure
-# with ssl access.
-#      on usage, you have to install vdr-live
-#      with USE="ssl"
-#
-#      SSL ADDRESS -->  https://<your-ip>:8443/
-#
-#      allowed values: yes no
-#      default: no
-#LIVE_USE_SSL="yes"
-
-# default given portnumber
-# only changes needed on problems
-#
-#LIVE_PORT="8008"
-#LIVE_SSL_PORT="8443"
-
-# bind to these IP addresses
-# default, your IP will automaticly detected
-#
-LIVE_BIND_IPS="127.0.0.1"
-
-# for people who have epgimges
-# default: /var/cache/vdr/epgimges
-#
-# set this to your own path, if needed
-#EPGIMAGES_DIR=" "
diff --git a/media-plugins/vdr-live/files/rc-addon-0.3.sh b/media-plugins/vdr-live/files/rc-addon-0.3.sh
deleted file mode 100644 (file)
index 1372e09..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-#
-# zzam@g.o
-# hd_brummy@g.o
-
-EPGIMAGES_DIR="/var/cache/vdr/epgimages"
-
-plugin_pre_vdr_start() {
-       if [ "${LIVE_USE_SSL:=no}" = "yes" ]; then
-               if [ -n "${LIVE_SSL_PORT}" ]; then
-                       add_plugin_param "-s ${LIVE_SSL_PORT}"
-               fi
-
-               add_plugin_param "--cert=/etc/vdr/plugins/live/live.pem"
-               add_plugin_param "--key=/etc/vdr/plugins/live/live-key.pem"
-
-       else
-               if [ -n "${LIVE_PORT}" ]; then
-                       add_plugin_param "-p ${LIVE_PORT}"
-               fi
-       fi
-
-       if [ -d ${EPGIMAGES_DIR} ]; then
-               add_plugin_param "--epgimages=${EPGIMAGES_DIR}"
-       fi
-
-       local ip
-       for ip in ${LIVE_BIND_IPS:=`hostname -i`}; do
-               add_plugin_param "-i ${ip}"
-       done
-}
diff --git a/media-plugins/vdr-live/files/vdr-live-0.3.0_p20130504-c++11.patch b/media-plugins/vdr-live/files/vdr-live-0.3.0_p20130504-c++11.patch
deleted file mode 100644 (file)
index e2bf96d..0000000
+++ /dev/null
@@ -1,153 +0,0 @@
-Bug: https://bugs.gentoo.org/599752
-
---- a/recman.cpp
-+++ b/recman.cpp
-@@ -22,10 +22,10 @@
-       /**
-        *  Implementation of class RecordingsManager:
-        */
--      weak_ptr< RecordingsManager > RecordingsManager::m_recMan;
--      shared_ptr< RecordingsTree > RecordingsManager::m_recTree;
--      shared_ptr< RecordingsList > RecordingsManager::m_recList;
--      shared_ptr< DirectoryList > RecordingsManager::m_recDirs;
-+      std::tr1::weak_ptr< RecordingsManager > RecordingsManager::m_recMan;
-+      std::tr1::shared_ptr< RecordingsTree > RecordingsManager::m_recTree;
-+      std::tr1::shared_ptr< RecordingsList > RecordingsManager::m_recList;
-+      std::tr1::shared_ptr< DirectoryList > RecordingsManager::m_recDirs;
-       int RecordingsManager::m_recordingsState = 0;
-       // The RecordingsManager holds a VDR lock on the
-@@ -53,7 +53,7 @@
-       {
-               RecordingsManagerPtr recMan = EnsureValidData();
-               if (! recMan) {
--                      return RecordingsTreePtr(recMan, shared_ptr< RecordingsTree >());
-+                      return RecordingsTreePtr(recMan, std::tr1::shared_ptr< RecordingsTree >());
-               }
-               return RecordingsTreePtr(recMan, m_recTree);
-       }
-@@ -62,25 +62,25 @@
-       {
-               RecordingsManagerPtr recMan = EnsureValidData();
-               if (! recMan) {
--                      return RecordingsListPtr(recMan, shared_ptr< RecordingsList >());
-+                      return RecordingsListPtr(recMan, std::tr1::shared_ptr< RecordingsList >());
-               }
--              return RecordingsListPtr(recMan, shared_ptr< RecordingsList >(new RecordingsList(m_recList, ascending)));
-+              return RecordingsListPtr(recMan, std::tr1::shared_ptr< RecordingsList >(new RecordingsList(m_recList, ascending)));
-       }
-       RecordingsListPtr RecordingsManager::GetRecordingsList(time_t begin, time_t end, bool ascending) const
-       {
-               RecordingsManagerPtr recMan = EnsureValidData();
-               if (! recMan) {
--                      return RecordingsListPtr(recMan, shared_ptr< RecordingsList >());
-+                      return RecordingsListPtr(recMan, std::tr1::shared_ptr< RecordingsList >());
-               }
--              return RecordingsListPtr(recMan, shared_ptr< RecordingsList >(new RecordingsList(m_recList, ascending)));
-+              return RecordingsListPtr(recMan, std::tr1::shared_ptr< RecordingsList >(new RecordingsList(m_recList, ascending)));
-       }
-       DirectoryListPtr RecordingsManager::GetDirectoryList() const
-       {
-               RecordingsManagerPtr recMan = EnsureValidData();
-               if (!recMan) {
--                      return DirectoryListPtr(recMan, shared_ptr< DirectoryList >());
-+                      return DirectoryListPtr(recMan, std::tr1::shared_ptr< DirectoryList >());
-               }
-               return DirectoryListPtr(recMan, m_recDirs);
-       }
-@@ -260,21 +264,21 @@
-                               m_recDirs.reset();
-                       }
-                       if (stateChanged || !m_recTree) {
--                              m_recTree = shared_ptr< RecordingsTree >(new RecordingsTree(recMan));
-+                              m_recTree = std::tr1::shared_ptr< RecordingsTree >(new RecordingsTree(recMan));
-                       }
-                       if (!m_recTree) {
-                               esyslog("[LIVE]: creation of recordings tree failed!");
-                               return RecordingsManagerPtr();
-                       }
-                       if (stateChanged || !m_recList) {
--                              m_recList = shared_ptr< RecordingsList >(new RecordingsList(RecordingsTreePtr(recMan, m_recTree)));
-+                              m_recList = std::tr1::shared_ptr< RecordingsList >(new RecordingsList(RecordingsTreePtr(recMan, m_recTree)));
-                       }
-                       if (!m_recList) {
-                               esyslog("[LIVE]: creation of recordings list failed!");
-                               return RecordingsManagerPtr();
-                       }
-                       if (stateChanged || !m_recDirs) {
--                              m_recDirs = shared_ptr< DirectoryList >(new DirectoryList(recMan));
-+                              m_recDirs = std::tr1::shared_ptr< DirectoryList >(new DirectoryList(recMan));
-                       }
-                       if (!m_recDirs) {
-                               esyslog("[LIVE]: creation of directory list failed!");
-@@ -543,13 +547,13 @@
-        *  Implementation of class RecordingsTreePtr:
-        */
-       RecordingsTreePtr::RecordingsTreePtr() :
--              shared_ptr<RecordingsTree>(),
-+              std::tr1::shared_ptr<RecordingsTree>(),
-               m_recManPtr()
-       {
-       }
-       RecordingsTreePtr::RecordingsTreePtr(RecordingsManagerPtr recManPtr, std::tr1::shared_ptr< RecordingsTree > recTree) :
--              shared_ptr<RecordingsTree>(recTree),
-+              std::tr1::shared_ptr<RecordingsTree>(recTree),
-               m_recManPtr(recManPtr)
-       {
-       }
-@@ -587,7 +591,7 @@
-               }
-       }
--      RecordingsList::RecordingsList(shared_ptr< RecordingsList > recList, bool ascending) :
-+      RecordingsList::RecordingsList(std::tr1::shared_ptr< RecordingsList > recList, bool ascending) :
-               m_pRecVec(new RecVecType(recList->size()))
-       {
-               if (!m_pRecVec) {
-@@ -601,7 +605,7 @@
-               }
-       }
--      RecordingsList::RecordingsList(shared_ptr< RecordingsList > recList, time_t begin, time_t end, bool ascending) :
-+      RecordingsList::RecordingsList(std::tr1::shared_ptr< RecordingsList > recList, time_t begin, time_t end, bool ascending) :
-               m_pRecVec(new RecVecType())
-       {
-               if (end > begin) {
-@@ -643,8 +647,8 @@
-       /**
-        *  Implementation of class RecordingsList:
-        */
--      RecordingsListPtr::RecordingsListPtr(RecordingsManagerPtr recManPtr, shared_ptr< RecordingsList > recList) :
--              shared_ptr< RecordingsList >(recList),
-+      RecordingsListPtr::RecordingsListPtr(RecordingsManagerPtr recManPtr, std::tr1::shared_ptr< RecordingsList > recList) :
-+              std::tr1::shared_ptr< RecordingsList >(recList),
-               m_recManPtr(recManPtr)
-       {
-       }
-@@ -712,8 +716,8 @@
-       /**
-        *  Implementation of class DirectoryListPtr:
-        */
--      DirectoryListPtr::DirectoryListPtr(RecordingsManagerPtr recManPtr, shared_ptr< DirectoryList > recDirs) :
--              shared_ptr< DirectoryList >(recDirs),
-+      DirectoryListPtr::DirectoryListPtr(RecordingsManagerPtr recManPtr, std::tr1::shared_ptr< DirectoryList > recDirs) :
-+              std::tr1::shared_ptr< DirectoryList >(recDirs),
-               m_recManPtr(recManPtr)
-       {
-       }
---- a/tasks.cpp
-+++ b/tasks.cpp
-@@ -253,8 +253,8 @@
-               current->Action();
-               m_taskQueue.pop_front();
-       }*/
--      for_each( m_taskQueue.begin(), m_taskQueue.end(), bind( &Task::Action, _1 ) );
--      for_each( m_stickyTasks.begin(), m_stickyTasks.end(), bind( &Task::Action, _1 ) );
-+      for_each( m_taskQueue.begin(), m_taskQueue.end(), std::tr1::bind( &Task::Action, _1 ) );
-+      for_each( m_stickyTasks.begin(), m_stickyTasks.end(), std::tr1::bind( &Task::Action, _1 ) );
-       m_taskQueue.clear();
-       m_scheduleWait.Broadcast();
- }
diff --git a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild
deleted file mode 100644 (file)
index 9ecf777..0000000
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit vdr-plugin-2 ssl-cert
-
-DESCRIPTION="VDR Plugin: Web Access To Settings"
-HOMEPAGE="http://live.vdr-developer.org"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
-               https://dev.gentoo.org/~hd_brummy/distfiles/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="pcre ssl"
-
-DEPEND="media-video/vdr
-       >=dev-libs/tntnet-2.2.1[ssl=]
-       >=dev-libs/cxxtools-2.2.1
-       pcre? ( >=dev-libs/libpcre-8.12[cxx] )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P}"
-
-VDR_CONFD_FILE="${FILESDIR}/confd-0.3"
-VDR_RCADDON_FILE="${FILESDIR}/rc-addon-0.3.sh"
-
-KEEP_I18NOBJECT="yes"
-
-PATCHES=(
-       "${FILESDIR}"/${P}_vdr-2.1.2.diff
-       "${FILESDIR}"/${P}-c++11.patch
-)
-
-make_live_cert() {
-       # TODO: still true?
-       # ssl-cert eclass creates a "invalid" cert, create our own one
-       local base=$(get_base 1)
-       local keydir="/etc/vdr/plugins/live"
-
-       SSL_ORGANIZATION="${SSL_ORGANIZATION:-VDR Plugin Live}"
-       SSL_COMMONNAME="${SSL_COMMONNAME:-`hostname -f`}"
-
-       echo
-       gen_cnf || return 1
-       echo
-       gen_key 1 || return 1
-       gen_csr 1 || return 1
-       gen_crt 1 || return 1
-       echo
-
-       install -d "${ROOT}${keydir}"
-       install -m0400 "${base}.key" "${ROOT}${keydir}/live-key.pem"
-       install -m0444 "${base}.crt" "${ROOT}${keydir}/live.pem"
-       chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live{,-key}.pem
-}
-
-src_prepare() {
-       default
-
-       # new Makefile handling ToDp
-#      cp "${FILESDIR}/live.mk" "${S}/Makefile"
-
-       # remove untranslated language files
-       rm "${S}"/po/{ca_ES,da_DK,el_GR,et_EE,hr_HR,hu_HU,nl_NL,nn_NO,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
-
-       vdr-plugin-2_src_prepare
-
-       if ! use pcre; then
-               sed -i "s:^HAVE_LIBPCRECPP:#HAVE_LIBPCRECPP:" Makefile || die
-       fi
-}
-
-src_install() {
-       vdr-plugin-2_src_install
-
-       insinto /usr/share/vdr/plugins/live
-       doins -r live/*
-
-       fowners -R vdr:vdr /usr/share/vdr/plugins/live
-}
-
-pkg_postinst() {
-       vdr-plugin-2_pkg_postinst
-
-       elog "To be able to use all functions of vdr-live"
-       elog "you should emerge and enable"
-       elog "media-plugins/vdr-epgsearch to search the EPG,"
-       elog "media-plugins/vdr-streamdev for Live-TV streaming"
-
-       elog "The default username/password is:"
-       elog "\tadmin:live"
-
-       if use ssl ; then
-               if [[ -f ${ROOT}/etc/vdr/plugins/live/live.pem ]]; then
-                       einfo "found an existing SSL cert, to create a new SSL cert, run:\n"
-                       einfo "emerge --config ${PN}"
-               else
-                       einfo "No SSL cert found, creating a default one now"
-                       make_live_cert
-               fi
-       fi
-}
-
-pkg_config() {
-       make_live_cert
-}